This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by elisabethL-3 1 year ago.

Assigned support staff: Rajeeb Banstola.

Author Posts
May 21, 2019 at 7:39 pm #3858521


Hi, I translated a page but when I click on the switcher or menu, it would give the error message, "The theme directory "twentyseventeen" does not exist". However, the theme I'm using is not "twentyseventeen" (it is "albert")

Thanks in advance for your help.

May 21, 2019 at 8:34 pm #3858749

Rajeeb Banstola


Thank you for contacing WPML support. I'll be glad to help you.

I tested a couple of scenarios on my local environment and got a similar error message. The error points that the active theme is listed as twentyseventeen, however the theme was probably deleted off your site.

Easiest way here is to install and activate TwentySeventeen and then activate your theme - 'Albert' which should change the value in database as well.

If you are tech savy, you can directly go to phpMyAdmin, go to wp_options table and look for current_theme option and set it to 'albert'

Let me know if you need any help on this!

May 22, 2019 at 9:27 am #3863765


Thanks Rajeeb,

Had tried activating themes as you said ... also checked the wp_options table ... still got the same error message. Actually the theme ('albert') works well. However, I noticed in the file directory, wp-content/languages/themes ... the themes folder is empty ... not sure, maybe missing some mo, po files ?
Kind regards

May 22, 2019 at 8:14 pm #3868947

Rajeeb Banstola


The language folder being empty should not be the cause of the issue.

I'd like to have you try a few things so we can try to isolate the issue. This is just to help us identify if it might be a conflict with another plugin or theme that is causing the problem.

IMPORTANT: Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

Please let us know so we can proceed further from here!

May 25, 2019 at 9:48 pm #3890171


Hi tried your instructions but unfortunately still the same error message ...

May 28, 2019 at 11:38 pm #3910533

Rajeeb Banstola


Thank you for your patience.

I would like to try a couple on your site so that we can resolve this. Can you please provide WordPress login details for your site?

I would also need permissions to do things like change theme or possibly change some WPML Settings. Let me know if that's okay with you or not.

I have marked your next reply as private so that only you and I can see the details.

May 29, 2019 at 3:48 pm #3917081


Hi, the thread does not seem to be marked private ?

May 29, 2019 at 8:11 pm #3918533

Rajeeb Banstola


I've enabled the private reply again. Please reply with login details.

May 30, 2019 at 12:09 am #3919147



May 30, 2019 at 10:35 pm #3926413

Rajeeb Banstola


Thank you for your patience.

I was able to confirm the language selector works when I select "Language name added as a parameter" option in WPML - Languages - Language URL format.

I do see that "Different languages in directories" is not working. It throws 404 error when this option is enabled. In order to make language directories working, you need to make sure URL rewriting is enabled on your server and in WordPress.

Please take a look at this documentation on faq about activating language directories:

I didn't see the original error "The theme directory "twentyseventeen" does not exist" you reported.

If you can provide us detailed steps on how to replicate the error, I'll be happy to look into it more.

Please let me know!

May 30, 2019 at 11:22 pm #3926547


Hi Rajeeb,

Yes indeed, I just checked it actually works fine now. Not sure, had done a series of changes today so maybe somehow it got resolved. Anyway, thanks a lot for all help and advise. Closing with this 🙂 Best regards

May 30, 2019 at 11:24 pm #3926549


Thank you!