Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by jamesP-5 2 years, 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 26, 2019 at 6:21 pm

jamesP-5

I am trying to: EDIT THE PAGE IN ADMIN DASHBOARD, IN ITALIAN BUT THE TEXT IS TOTALLY MESSED.

Link to a page where the issue can be seen:

I expected to see: NORMAL SITUATION, LIKE IN ENGLISH

Instead, I got: MANY WORDS IN THE TITLES OF DASHBOAD MENU

text-messing-italiano2.png
text-messing-italiano.png
February 26, 2019 at 6:23 pm #3246757

jamesP-5

I have this problem only with the string translation plug-in active

February 26, 2019 at 6:24 pm #3246759

jamesP-5

Also I updated all plug-ins to the latest version

February 27, 2019 at 5:58 am #3248536

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

This looks to me like a compatibility issue. Can you please follow the steps below and let me know if the issue is still happening?

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 28, 2019 at 12:11 am #3252805

jamesP-5

Hello,
thanks for your response. I did all the steps that you mentioned. Also I changed the theme to he standard WP. No issue solved. The only way to solve the problem is to deactivate the string translator plug-in.
I really need the site working again, any other suggestion please?
Thank you

February 28, 2019 at 12:12 am #3252808

jamesP-5

This is how I see after doing all the steps that you suggested.

theme-active.png
Issue-text-scramble.png
February 28, 2019 at 4:53 pm #3256657

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the update.

I will spend some more time on this.

If needed, do I have your permission to disable/activate different plugins/themes for short periods of time?

Or, if not, do I have your permission to replicate your site locally?

If you prefer the second option, I will need your written approval to be able to duplicate your site using a plugin called "Duplicator" and test your site on a local environment so can you please let me know if this is ok with you?

I will be waiting for your response.

Kind regards,
Mihai

March 14, 2019 at 12:24 am #3338995

jamesP-5

Hi,
I give the permission to replicate locally the website and make tests to find a solution to fix this problem.
Thanks

March 14, 2019 at 6:06 pm #3347813

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the confirmation!

I will get back to you as soon as I have new findings on this issue.

Kind regards,
Mihai

March 15, 2019 at 2:17 am #3349641

jamesP-5

Hi,
this is perfect! I hope that can help.
Thanks a lot.

March 16, 2019 at 6:56 am #3359081

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I spent some time on the site and I do find that a really weird issue. Also, from what I can see, it happens only when the IT language is switched-to in the backend. For the English language, things seem to look fine.

1. Can you please let me know if you had experienced any server issues recently or any malware hack? I never saw that kind of behavior.

2. Also, can you please let me know if you had the chance to follow the next steps (make sure that you first do a full website backup)?

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

3. I would need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents through a link - using a service like pastebin.com.

Please let me know what you will be able to find.

I will be waiting for your reply!

Kind regards,
Mihai

March 18, 2019 at 7:55 pm #3372849

jamesP-5

Hi, before all thank you for spending some time on this site to try to fix and figure out the issue.
In fact it is a weird issue. I don't think I had malware hack, the laptop that I use to update the site has latest Norton antivirus.
I have done all the steps that you mention: disable all plug-in except WPML, swith the theme to TwentySeventeen, and try to activate one by one. But nothing change of fix the issue.
I have done the changes in the wp-config.php accoding to your suggestion. And activated the plug-in String Translator, that causes the error.
I noticed that it created the file log error, that I send the link.
Bu also I cannot see that error because when I try to switch tranlsation from english to italian it open the page with wpml translator (which is not corret, I want to edit the page with WORDPRESS editor. But even I change "Use WPML's Translation Editor - OFF" it doen't work at all. Please see attachment images.
PASTEBIN error log.txt: https://pastebin.com/bFash5zm
Thank you

Edito-translation-2.jpg
Edito-translation.jpg
March 18, 2019 at 8:17 pm #3373101

jamesP-5

Plase also check this second error log: https://pastebin.com/XTaqt6Jq

March 19, 2019 at 6:24 pm #3382541

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you very much for the extra information!

There has surely happened something with the WPML strings as I can see that straight in the WPML > String Translation that the translations for the "sitepress" domain are wrong (I will also attach a screenshot as an example).

The debug log doesn't show any sign regarding this issue so I will need to spend some more time on this and after I will have tried a few more tests, I will be able to get back to you some new feedback.

The other alternative would be to wait until WPML will have a new update (that should also happen pretty soon) because each time you install a new plugin version (WPML or any other plugin), what WPML does is that it scans for the strings once again and this issue should be solved at that moment but I want to try something else to see if that will be able to solve the issue so that you won't have to wait for the next WPML update.

From what I can see, this issue is happening only for the main site (centro pro unione). I tested that on the "Bulletin" site and everything was looking alright.

I will leave this ticket assigned to myself.

I will keep you updated.

Kind regards,
Mihai

Screenshot 2019-03-19 at 19.23.18.png
March 21, 2019 at 4:50 pm #3413081

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hello.

I just wanted to update you so that you know what I am doing.

I am still testing on a few things and I hope that tomorrow the latest I will be able to come with more updates. Hopefully, I will be able to find a way to remove the strings manually and then re-sync them.

I will keep you updated and thank you for your patience in the process.

Kind regards,
Mihai