Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by jamesP-5 2 years, 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 22, 2019 at 1:41 am #3433741

jamesP-5

Hello,
thank you for the updates and the news since here about the tests.
I remain waiting kindly for some news about it.
Thank you,
regards

March 22, 2019 at 1:33 pm #3440593

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hello and thank you so much for your patience while this long and complex testing process.

I did my best to try to replicate the issue and find a fix for it but I wasn't able to do it.

I am pretty sure that this issue happened in connection with your host as it seems it has some limitations (by the way, I had so many issues with the host/server that the website is currently on - I was not able to create any duplicator backup - I tried with both the free "Duplicator" version and also the pro version "Duplicator pro" but it was continuously telling me that because of the hosting limitation, the plugin was not able to create a backup).

So, I had to go with a manual backup that was also difficult to do due to the fact that the site you are having is set up as a multisite.

The conclusion here is that we have 2 options going forward:

1. Create a full backup of the current multisite

2

a. You can try updating to a beta version
b. You can wait until we will release a stable version in the close future

Whatever option you would choose, please do not forget to have a full backup done of the whole multisite. You can even get in touch with the hosting and have them do it so that you won't risk losing any data due to the hosting limitations.

I would love to hear that you managed to solve this and it would be amazing if you could come back here and let me know if any of the 2 options solved the issue for you. I have not seen any other people until now experiencing the same issue you are experiencing but I'm sure that it would be helpful to have written in this ticket the solution that worked for you as that might help other people that might find in the same place you are right now in the close future.

If I would have to pick, I would probably prefer to update the site when there's a stable version available but if you have a full backup, you should be safe trying a beta version, too.

I will also leave a screenshot for you so that you can see how you can find a beta version for the main WPML plugin to install on the site.

I think you could also go this route, too:
https://wpml.org/faq/how-to-install-beta-and-development-versions-of-wpml/

I can't wait to see this issue being solved.

Please let me know what you will decide 🙂

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

Screenshot 2019-03-22 at 15.25.22.png
April 2, 2019 at 12:48 am #3512239

jamesP-5

Hi, I take some days to do the task.
I downloaded the beta version of the plug-ins WPML and deactivated the old ones and installed the new ones.
I am sad to say the issue is NOT solved, I have still in the first multisite only in italian language some weird text taking place in the WP dashboard. This is painfull and deny me to act properly in my site due to this WPML issue. I really wish this can be solved. What can I do now?

still-italian-weird-text-dashboard.png
April 2, 2019 at 1:03 am #3512273

jamesP-5

I also reinstalled WP core 5.1.1, no results. Where is the issue? What cause it?
I noticed that the words that appear in wrong place some come form the plug-in WP GDPR hidden link and I try to deactivate it, but nothing happens. Should I delete completly this plug-in in order to see what happens?

April 2, 2019 at 1:17 am #3512379

jamesP-5

Also the situation in italian language become normal when I deactivate the plug-in "String Translator". I think it this plug-in that causes the conflict.

deactivated-string-translator-text-dashboard.png
April 2, 2019 at 2:37 pm #3518359

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for getting back to me.

I am really sorry to hear that the issue doesn't go away.

I will open an internal ticket for this issue and I will send it to our developers.

Once I have any feedback, I will get back to you.

I will also set the status of this current ticket to "Escalated to WPML developers team".

We will keep in touch.

Kind regards,
Mihai

April 11, 2019 at 11:16 am #3586511

jamesP-5

Thank you, I will be waiting for any solution on this.
Regards!

April 12, 2019 at 1:00 pm #3599121

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am getting back to with a recommendation to see if that will fix anything.

Also, from what I can see, only the "WordPress dashboard > Plugins" Italian area is now affected and the WPML options look right, I don't know if you did anything on the site but it seems that the issues in the WPML panel are not showing up anymore and the strings show up correctly.

1. As a workaround, our developers said that you could clear the icl_strings and icl_string_translation tables in the database, only in the case where you haven't translated any string yet. WPML will scan and import the MO file again so that will not be an issue

2. If that doesn't solve the issue, can you please provide a DB dump of the main site only (the "prounione" one)?

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

May 7, 2019 at 5:11 pm #3760963

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

I am reopening this ticket as it got closed automatically by our system due to no replies for more than a few days.

I will be waiting for an answer from you regarding my last message in this ticket (https://wpml.org/forums/topic/messing-text-in-dashbord-italian-language-with-string-translation-active/page/2/#post-3599121) as the internal ticket I created in our developers team system regarding your situation is still open and I will need what I requested above so that we can make this situation go forward.

I will be waiting for your reply.

I am at the end of my shift at the moment but I will be able to get back to you tomorrow in case you will respond tonight.

Kind regards,
Mihai

May 14, 2019 at 2:25 pm #3808127

jamesP-5

Hello!
My answear below:

1. As a workaround, our developers said that you could clear the icl_strings and icl_string_translation tables in the database, only in the case where you haven't translated any string yet. WPML will scan and import the MO file again so that will not be an issue

(I need to do it in the phpMyAdmin?)

2. If that doesn't solve the issue, can you please provide a DB dump of the main site only (the "prounione" one)?

(Yes, of course. Whats is the e-mail address where I can send the dump?)

May 15, 2019 at 2:10 pm #3817539

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

1. Yes, if you have "phpMyAdmin", you can use that.

2. In case that doesn't work, you can upload the database zip onto a file sharing service like Google Drive or Dropbox and share the link with me.

Let me know how that goes.

Kind regards,
Mihai

May 22, 2019 at 9:35 pm #3869423

jamesP-5

Hi,
here is the database dump for Prounione

hidden link

thanks

May 30, 2019 at 12:50 am #3919267

jamesP-5

Hi,
any news for me, please?
Thanks

June 4, 2019 at 8:10 pm #3955077

jamesP-5

Hello, any news? My site is still broken due to the WPML plug-in and I need still support here. Thanks