Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by stefanK-4 3 years, 10 months ago.

Assigned support staff: Yvette.

Author Posts
December 2, 2017 at 3:25 pm


I am trying to: Translate meta descriptions for custom post types, it does not show up in string translation table for me to translate. We want to assign a static meta description for specific custom post type posts. So we went to "Titles and Metas", then "Content Type" and then added the meta description for some custom post types. But the meta description is not showing in the string translation table. So we cannot translate the meta description.

Link to a page where the issue can be seen: hidden link

I expected to see: The Translated (French) meta description for the specific custom post types.

Instead, I got: The default (English) meta description.

We are using WPML version 3.8.4

December 5, 2017 at 8:37 am #1449317


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)


This was a bit tricky. For WP SEO admin fields, you need to save the initial values with the WPML default language set to English. This will register the values with String Translation. Then, you can change the string language to French and also change the system default language back to French.

These admin strings are now showing up in String Translation.

Can you confirm this is working for you now?


December 5, 2017 at 2:27 pm #1449823


Hello Yvette,
Thank you for your reply. However there are still some meta description fields that are not registered in the string translation table. Please see the screenshot. Also can you please explain the steps to resolve the issue a bit clearly ? Thanks again !

December 5, 2017 at 7:05 pm #1450168


Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Sorry I missed those.

1. Determine the option key for the text you want to translate using Adminer
(see image) This will be stored for the option wpseo_titles

2. Add the option key for the title that should be added to the tab
WPML -> Translation Management -> Custom XML Configuration (see image)

3. Change your WPML default language to English

4. Save the titles and metadescriptions you have configured
The saving will trigger the hook to register the texts with String Translations

5. Switch the WPML default language back to French

6. Translate the registered strings

December 5, 2017 at 7:44 pm #1450204


Thanks a lot. That worked perfectly 🙂

April 17, 2018 at 9:50 am #1657689


I have the same problem, but I afaik the image for step 1 is missing? The rest of the solution I can follow/understand...

Edit: changing the default language to English and scanning all plugins and themes for new strings fixed it for me.