This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The meta description is not translated correctly using the All in One SEO plugin.

Solution: These strings must be manually entered for translation:

- Click on the WPML > String Translation - At the end of the page, click on the Translate texts in admin screens » link - Search for the desired strings and select it - At the end of the page, click on the "Apply" button - Click on the WPML > String Translation

The strings should have been added for translation.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/

Related documentation: String Translation

This topic contains 10 replies, has 2 voices, and was last updated by  diegoA 2 years, 4 months ago. The support staff assigned to this topic is Bruno.

Author Posts
Author Posts
April 25, 2016 at 3:14 pm #868548

diegoA

I am trying to: Translate meta description but it's not appearing in translate streams

URL of (my) website where problem appears: hidden link

I expected to see: the meta title is appearing and it's translated but the meta description is not.

Please help

April 25, 2016 at 3:59 pm #868587

diegoA

I also see that in my posts strings like "comments" and "read more" are not able to be translated. I cannot find those strings in the strings pending to be translated . Please help,

April 26, 2016 at 1:50 pm #869335

Bruno
Forum moderator

Supporter languages: English (English ) Portuguese (Brazil) (Português )

Supporter Timezone: America/Sao_Paulo (GMT-03:00)

Hi Diego,

Thanks for contacting us.

In translation page you must translate the title and description in the All In One SEO custom fields. I will attach a picture for you to see.

- On the WordPress dashboard, open the desired post and switch to the secondary language
- Look for "All in One SEO Pack"
- Translate the Title and Description field
- Click on the Update button.

May I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

April 26, 2016 at 2:13 pm #869361

diegoA

Sorry, but you didn't understand my question or I did't know how to explain it. I have already fulfill all the date in the All in one Seo Menu corresponding to the SEO for the webpage (Title, description and keyword). The problem is that when I go to translations strings in the WPML menu only Keywords and Title appear under AIOSeo strings, so the Web description is missed and does not appear there to be translated. Please help.

April 26, 2016 at 6:23 pm #869591

Bruno
Forum moderator

Supporter languages: English (English ) Portuguese (Brazil) (Português )

Supporter Timezone: America/Sao_Paulo (GMT-03:00)

Hi Diego,

That would be the description that will be displayed on the homepage, is that correct? If so, clicking on the "All in One SEO" > "General Settings", look for "Home Page Settings" box.

You have already added the description in this field? If so, then the string must have been added to the tradition String Translation.

Note that there are two strings "description". One is that the format description is displayed. The other is the description of the home. These two are added within the String Translation.

The other descriptions of pages and posts are added individually within each edit page, as I posted above.

Looking for home description, you do not find in the String Translation, despite having already added content in the default language ( "All in One SEO" > "General Settings" )?

Thank you.

April 26, 2016 at 6:38 pm #869614

diegoA

Hola, that's the problem. The string for HOME DESCRIPTION is not appearing and i have fulfill the home description in the seo general options. Please take a look at the screen I already sent you in order to check that only keywords and title are set to be translated (the two first lines) but NOT home description...

April 26, 2016 at 8:19 pm #869691

Bruno
Forum moderator

Supporter languages: English (English ) Portuguese (Brazil) (Português )

Supporter Timezone: America/Sao_Paulo (GMT-03:00)

Hi Diego,

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please let me know exactly what steps should I follow to see the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

April 27, 2016 at 1:20 pm #870208

Bruno
Forum moderator

Supporter languages: English (English ) Portuguese (Brazil) (Português )

Supporter Timezone: America/Sao_Paulo (GMT-03:00)

Hi Diego,

Thank you. I saw the problem. I scanned the plugins, but the string was not added to the string translation.

Please, I can install the Adminer plugin ( https://wordpress.org/plugins/adminer/ ) to check your database?

Also, please, could you update WPML plugins to the latest version, which was released today?

Thank you.

April 27, 2016 at 1:36 pm #870219

diegoA

yes you can. I updated the plugin but the problem is still there.

April 27, 2016 at 7:16 pm #870588

Bruno
Forum moderator

Supporter languages: English (English ) Portuguese (Brazil) (Português )

Supporter Timezone: America/Sao_Paulo (GMT-03:00)

Hi Diego,

I fixed your site. Please could you check it is working as intended? I will attach a picture for you to see.

Just click on the WPML > String Translation, and look for the desired string.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

April 28, 2016 at 7:16 am #870753

diegoA

solved!