This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 6 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
April 5, 2019 at 9:46 am #3542681

robbertv-5

Hi

I have a setup for my store in NL en EN languages.
We are working with the option to show the translation whit out duplication of the post/product/page.

I have done the string translation of yoast title en description snippets.

The translation of EN meta title and description do not show up in the DOM.

April 5, 2019 at 4:30 pm #3545915

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @robbertv-5, welcome to the WPML support Forum!

Could you send us a link of a page/post with the issue? We will take a look.

I noticed that you are using a cache plugin. Could you clear the caches and check if the issue persist?

PS: Please also update WPML + extensions to the lastest version. You can download from here: https://wpml.org/account/downloads/

All the best,
Diego

April 12, 2019 at 8:02 am #3595951

robbertv-5

Hi Diego,

Its on all product pages. You have the url in the report?
Dont wan't to share urls, because topic stays public.

We have checked all cache nothing in there.

Did you try it on your system if it works at all?
It looks like its not supported (when pages are not copied)

April 12, 2019 at 8:43 am #3596539

robbertv-5

I did a clean install with the latest plugins, but the yoast (seo title) string does not show up?

April 12, 2019 at 5:56 pm #3601151

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

So, the same issue occurs on a clean install? Could you send us access to this clean install, or, if you prefer, reproduce it on this test site? hidden link - It's a clean WP install with WPML installed. It's quicker to check on a clean install so we will be able to test if it's a compatibility issue with WPML or not.

Kind regards,
Diego

April 13, 2019 at 8:07 am #3603901

robbertv-5

Hi
I made a page (Meta title & description)

- show in other languages when not translated (works)
- edited (yoast) meta title and description
- does not show up in string translation

April 15, 2019 at 1:54 pm #3613893

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. I checked the test install. You need to create a new translation for the page by clicking on the "+" icon in order to translate the meta title and description. This step is required for all pages and posts. Please take a look at this link: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/#%22translate-page-seo-attributes

After that, the translated meta-description is displayed on hte portuguese version: hidden link

The String Translation is required to translate the front-page only if you have not selected a static homepage on the Settings -> Reading page. Please chekc this link: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/#translating-the-seo-texts

This is the complete documentation: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml

Please let me know if it worked for you.

Kind regards,
Diego