This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Noman 3 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 12, 2019 at 4:29 pm #4006135

Yair Lehmann

I am trying to: View a slideshow on a Hebrew page on a multilingual site. The same slideshow works on the English page but not on the Hebrew page.

Link to a page where the issue can be seen:

hidden link

On the English page you can see the slideshow:

hidden link

I expected to see: The slideshow. All I see are the captions and the images are not there. If you look at the html in the English and Hebrew page for the slider items the attributes are different.

Instead, I got: Just a blank slideshow with captions of pictures but not the pictures themselves.

June 13, 2019 at 5:14 am #4009513

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support.

- Could you please make sure you have followed our step by step guide for meta slider translation:
https://wpml.org/2016/08/translate-meta-slider-plugin-using-wpml/

- You are using an older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions. You can download it from your account: https://wpml.org/account/downloads/

- Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.6.40 which is good, but it's advised is to use more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

- Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporary.

Thank you

June 17, 2019 at 5:33 pm #4037543

Yair Lehmann

Hi,

I updated the wpml plugins. I don't want to update the php at this point b.c. that caused an issue for the site the last time we tried it.

Anyway, as far as metaslider translation is concerned, I actually am using two different sliders one for the English page and one for the Hebrew. And the translation is the English one (we start from the Hebrew and then convert the page to English).

However, the translation is working fine, its the Hebrew that is the problem. And its just sometimes a problem on chrome and IE, it looks ok on firefox.

I deleted caches.

Please see these two links, its just an example page:

Hebrew page:

hidden link

English page (which is the translation of the page, but has a different slider entirely):

hidden link

June 18, 2019 at 12:38 pm #4043847

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow these steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results.

Thank you

June 21, 2019 at 12:31 pm #4067193

Yair Lehmann

Hi,

Ok, I did what you suggested.

Here is a summary of what happened:

1. I activated the wordpress 2019 theme, activated all wpml plugins and the metaslider plugin only: The Hebrew page slideshow works on chrome, but does not work on firefox.

Then I activated the other plugins one by one (except the two main Avada plugins) and same, slideshow showing up on chrome but not on firefox.

2. Then I switched to the Avada theme and the slideshows no longer work on chrome and pictures are not showing on chrome. However, now the slideshows show the pictures and work on firefox.

Anyway, after all this something had gotten messed up with the widgets so I restored the previous database version from before (when the slideshow wasn't working on firefox and chrome). No idea why just deactivating and reactivating plugins would make a difference in terms of it showing up on firefox.

But in any case, do you have input about any of this? Like, how to get the metaslider working on the Hebrew page for both firefox and chrome at the same time (and IE also, which I didn't check b.c. I don't have it in stalled here and its not a windows machine).

Thanks,

June 23, 2019 at 3:39 pm #4073225

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for doing above steps. To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 27, 2019 at 7:17 am #4097239

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for the login info. I am working on this issue and get back to you with my findings.

Thank you for your cooperation and patience.

June 27, 2019 at 7:38 pm #4102661

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have disabled WPML plugin in your site and still Meta Slider not working in Hebrew language. It looks like some compatibility issue between meta slider and Hebrew language. I recommend you to please ask ‘Meta Slider’ plugin author so they can advise you on latest compatibility of their plugin and Hebrew language, may be they have a fix for it.

Thank you

The topic ‘[Closed] MetaSlider plugin slideshow doesn't work on Hebrew page’ is closed to new replies.