Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
December 4, 2019 at 11:04 pm #5072879

rufusB

I have migrated my site using cloudways migrator to cloudways. The primary language site is now pretty much fixed but the second language is a mess, with hundreds of urls pointing to the primary site, half translated urls and primary site prefixes on the permalinks page. Added to that, many urls have lost the s on the end of http, possible due to prior problem installing a SLL.
In Setup WPML>Language URL format, neither site validates on save.

I followed https://wpml.org/forums/topic/my-website-keeps-redirecting-me-to-the-english-version/

This has not worked. How can I fix this?

https;//timbamerchant.es (secondary language)

December 9, 2019 at 4:07 am #5090119

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

Kindly apologize for the delay in response, Our subsequent replies will be much faster.

I have randomly checked your site I could not find any links pointing to the primary domain in the secondary language, Maybe I have missed something. Could you please help me with the steps to reproduce the issue?

I am not really why the product permalink displays primary URL in your screenshot. To have a better look, I would like to request temporary access (wp-admin and FTP) to your test site.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Kind regards
Raja

December 9, 2019 at 9:03 am #5090907

rufusB

Hi Raja, thanks for getting back. I am delighted that you are unable to find any broken links, I've spent the last few days repairing them.

I did find one setting in WPML which allowed the product permalink to be translated - I assume this setting had switched during the migration- but I continue editing thousands of urls manually.

What remains are thousands of links on single track pages. Here

hidden link

you will find two that point to the primary site-

Ver el álbum
is a primary site url in its entirety, though it does not reflect an update to the product permalink custom base (/product/ should now be /store/).

Ver la lista de Timba Y Salsa Cubana
points to timbamerchant.net- the primary site- but the rest is translated, again using the old product permalink custom base (/generos/ should now be /tienda/).

Is there a way to automatically update these urls?

Regarding access, if you could send me your email address to admin@timbamerchant.net I'll add you as a team member to my cloudways server.

December 9, 2019 at 2:46 pm #5093627

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, I hope running the WPML troubleshooting should fix the issue.

Please try executing the WPML default setting to adjust links, Secure a backup of your site and database before you proceed.

In your WordPress Dasboard > WPML > Settings > Translate Link Targets click the 'Scan now and adjust links'

Check if that helps.

If not please use my mail id raja.m@onthegosystems.com to share the access details.

Kind regards
Raja

December 10, 2019 at 7:14 pm #5102497

rufusB

I have scanned and adjusted links again but to no effect. You should receive an email allowing you to set your login. Cheers

December 11, 2019 at 5:47 am #5103963

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks, I am able to access the server now, However, what would be more beneficial is the access to your site dashboard. I am not able to access the site dashboard using the credentials from the cloudways > application > Access Details sections. When entering the details it says invalid

Please create separate temporary admin access to your site and share the details with me. (I didn't receive any email regarding the access to your site dashboard).

Kind regards
Raja

December 11, 2019 at 8:32 am #5104377

rufusB

Hi, hopefully this should work

raja.m@onthegosystems.com

from here
hidden link

To easily identify if translations are working I've updated all the English language single track urls from this album page hidden link (accessible through orange "select options" tabs.). The second language urls are not updated.

I haven't figured out how to set up a dual language staging site so please bear in mind this site is live.
Cheers,

Rufus

December 12, 2019 at 3:12 am #5111733

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the access, I am checking on this right now. I will update you in a while.

December 12, 2019 at 8:23 am #5112439

rufusB

Hi, could i ask you to stop and instead clone the site., Whatever you're doing is breaking the elementor image captions and urls. After I adjusted the links it did the same and I spent the entire day yesterday fixing them.

December 12, 2019 at 9:00 am #5112801

rufusB

Great, it's on its way to you. Changing settings and editing second language with string translator active does break elementor but curiously only one page seems to be affected at the moment so maybe it is something else this time :/

December 12, 2019 at 10:00 am #5113291

rufusB

It's arrived but off the home and menu pages will probably redirect to the live site. Enjoy!

December 12, 2019 at 11:52 am #5114549

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the migration, I will fix that.

Since only one page is affected try to manually correct them if possible. I can see some issues with the domain not retaining the login state maybe its a connected issue. checking further.

Kind regards
Raja

December 12, 2019 at 3:11 pm #5116399

rufusB

Just a thought that might have some bearing on this as I notice that permalinks for products update slightly differently from other pages.

I have tried to remove the woocommerce store and create the shop structure and appearance that I need. This has only been partially successful as search results direct to the shop page and its categories. All the same, there is currently no shop page set under woocommerce>products>shop page. Could that create issues with permalink updates

December 13, 2019 at 1:09 pm #5123537

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

You should have a valid shop URL, Please set the shop URL under woocommerce Settings. Without a valid shop URL, the translation will be unstable. You can see from here hidden link the shop page is empty with no translation for the shop URL.

Make sure the shop URL is correctly associated with the languages. Also bear in mind you already have "store" as the product base URL so choose a different shop URL.

Regarding the links not appearing as translated in product short description I can reproduce that in a clean installation, I am checking this with the team if that is expected or this needs to be reported.

Kind regards
Raja

December 20, 2019 at 12:30 am #5166881

rufusB

hi, I Made a new shop page and a redirect from it to where I want the shop to be. I then corrected all the primary language links and scanned, with predictable results for all the elementor pages. No links on the product pages were translated, however, so I'll just do it manually.