This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Bigul 1 year ago.

Assigned support staff: Bigul.

Author Posts
May 10, 2019 at 1:07 pm #3784591


I am trying to:
Have the mini cart in the header widget to show the default currency.

Link to a page where the issue can be seen:
hidden link (or .de/.fr/.it/.es)

I expected to see:
The mini cart to show it in correct translated language (in this case in dutch for and correct currency EURO

Instead, I got:
I see the mini cart in English language and English currency (GBP, which is not activated for .nl). Only when i put an item in the cart, it shows the correct currency EURO and correct translated string. Please see attached images

May 10, 2019 at 1:09 pm #3784673


Please also see attached image where multi-currency can be shown in correct setup

May 10, 2019 at 5:14 pm #3786999


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the older version of WPML and WooCommerce Multilingual. Please upgrade to the latest version of WPML(4.2.6) and WooCommerce Multilingual( after a full site backup and make sure the issue is existing or not.

I have a request. Please upgrade the following configuration for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link



The topic ‘[Closed] Mini cart on homepage showing second currency and second language’ is closed to new replies.