Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Harshad 9 years, 1 month ago.

Assigned support staff: Harshad.

Author Posts
November 8, 2012 at 10:16 am #83644

Dorian

Hi guys,
Seems like lots of people had similar errors before, but all of them were solved by 1-on-1 as far as I know. So here we go...

The Chinese version of my site is to be assigned to a "cn-" prefixed domain.
All step-by-step info described in the relevant WPML page was followed, and both our server's DNS + Apache config seem ready for action.

However, when I tell WPML to use the new domain, I just get the famous "Error: Data not saved" error. Nothing shows in the "error_log.txt" file.

I can visit the cn-prefixed url, but it simply shows the website in its default language (english). If I select Chinese from the drop-down language menu, I simply get the old /zh/ suffix added to the cn-prefixed url.

I've been using the "directories" mode for WPML up to now. Interesting thing is, in the Dashboard, WPML actually tells me that "It looks like languages per directories will not work... When WPML accesses hidden link it gets: HTTP code: 404 (Not Found)". Actually, the directories do work.

Another interesting fact: if I de-activate WPML, then visiting cn.meridian-online.com just gives a blank page.

Any advice?

Best,
Dorian

November 8, 2012 at 10:38 am #83654

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Dorian,

The first thing to look at is the versions of your WordPress, WPML and it's add-ons (if using any).

Make sure that everything is updated to the latest available version. Compare what you have against the version numbers you see under the "My Account -> Downloads" screen on this site.

Next, please review the information provided here: http://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

If nothing from the above helps, is it possible to have temporary wp-admin and FTP access to your installation?

Please email the info to [email]. Don't forget to use the topic of this thread in the subject line as referense.

November 9, 2012 at 12:49 pm #83808

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Dorian,

I received your email and the follow-up you sent.

cn.meridian-online.com/wp-admin redirects to hidden link which I cannot access.

You wrote that I do not have to change my "hosts" file. Is this still the case? Can you give me an update on this please as I would like to work on your ticket this afternoon.

Will be waiting for a reply. Thank you!

November 12, 2012 at 3:46 pm #84108

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Dorian,

Based on the information found here: http://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/ , calling: hidden link gives me correctly: <!--hidden link; in the source code.

This tells WPML that WordPress allows accessing this URL structure. The call passes so WPML will allow using languages per directories.

From an earlier comment I understand that the domain for the second language is cn.meridian-online.com, is this correct?

I can see the site just fine under cn.meridian-online.com which means "A different domain per language" works it's just that the setting is not saving.

Let's try this:

1. Follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/,

2. Repeat the action of saving the "Language URL format" setting

3. Copy and paste the contents of error_log.txt here for us to see

P.S I would have done this myself however the FTP login credentials you provided for me do not allow me to log in via FTP to your installation. If you like to correct that I can check the error log myself. Let me know.

November 12, 2012 at 4:34 pm #84126

Dorian

Hi Sarah,

I confirm that we would indeed like to use cn.meridian-online.com as the domain for all the Chinese content of our website.

I tried saving the setting again, but again, all I get is an "Error: Data not saved" message, and still nothing shows up in the "errors.log" file.

The login credentials I gave you should work, would you mind trying again? The server can be a bit slow, maybe retrying will enable you to connect.

Best,
Dorian

November 13, 2012 at 8:32 am #84227

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Dorian,

I have tried again to login via FTP but unfortunately the credentials I was given do not work.

I have send you an email regarding this.

November 23, 2012 at 12:51 pm #86186

Harshad

Dear Dorian,

When you call hidden link, if check the source, it returns

<!--hidden link;

Whereas it should show your main domain

<!--hidden link;

Theres something wrong with your configuration, can you please check with your hosting company if they have correctly setup the DNS
http://wpml.org/faq/server-setting-for-languages-in-different-domains/

November 24, 2012 at 5:48 pm #86388

Dorian

Hi Harshad,
Unfortunately, we're now going through a VPS server for our site, and our technicians lack a bit of expertise with this sort of config.

Besides, the documentation accessible on WPML's FAQ is rather sparce on these matters!

Am I right in understanding that basically, if our server's IP is xx.xx.xx.xx, then whatever stands for the equivalent of the "hosts" file on our server should be modified to point both domains to a same IP?
Can you please explain why this would establish one of those two domains as the main one?

Best,
Dorian

November 25, 2012 at 6:28 am #86404

Harshad

Yes, For ex. Your server ip is XX.XX.XX.XX then both the domains should point to same ip in hosts file

XX.XX.XX.XX  meridian-online.com
XX.XX.XX.XX  cn.meridian-online.com
November 26, 2012 at 2:52 am #86485

Dorian

Hi Harshad,

The thing is, we are currently trying to source all the Chinese-language content for our website from a mirror server located in China (while the main, English-language content is on a server in the States). This is necessary for us since we deal with visitors from both inside and outside of China, and web traffic can be painfully slow visiting foreign servers from within China (and vice-versa).

Therefore, the two servers we have at our disposal right now each have their own distinct IP address. How can we set up WPML so that content be sourced from 2 different IPs?

Best,
Dorian

December 1, 2012 at 7:58 am #87757

Harshad

Dear Dorian,

I am not sure how this can be achieved, As far as I know you will have to map the domains to the same IP as I described in my previous reply.

December 1, 2012 at 9:14 am #87766

Dorian

Dear Harshad,
Thanks for your reply, but can we please try to find out if there would be ways to use WPML without mapping everything to a same IP? We unfortunately lack technicians specialized in that field on our side, which is why we keep pestering you guys...!

We've spent a huge time adapting our website to WPML, in order to streamline the translation process and so on, but if we can't get around this problem we'll have to abandon the plug-in altogether... which would make us a little sad.

Thanks in advance,
Dorian

December 1, 2012 at 9:53 am #87767

Harshad

Dear Dorian,

Let me give a try something on this problem, Can you please send me your ftp and wp-admin details to my email address?

The topic ‘[Closed] mirror site on other domain - "Error: Data not saved"’ is closed to new replies.