This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 2 replies, has 2 voices.

Last updated by luisL-6 7 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 9, 2019 at 10:00 am #4721557


I am trying to: Translate portfolio content from the original content (spanish) in classic wpml editor

Link to a page where the issue can be seen: hidden link

I expected to see: all the fields and content to translate

Instead, I got: "title" and "translation priorities" fields all the others are missing.

I´ve spent a week trying to discover what am I doing wrong. Plugins and theme updated, checked and renewed wpml-config.xls.
Wpml cache cleaned, created new portfolio entries...
On pages and posts, the translation page is fine.

October 9, 2019 at 5:57 pm #4725009

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello, welcome to the WPML support Forum!

These elements are probably not registered for translation. You must register them according to this link: You can add the custom XML code to WPML > Settings > Custom XML Configuration.

After that, you may need to do a small modification on the page content of the original language in order to refresh the available fields.

Please let me know if it worked for you.

If you need more help, could you send us the shortcode of these elements? If it's simple we can generate the XML code for you.

All the best,

October 11, 2019 at 9:58 am #4736925


Hi Diego,
Thanks to try to fix the problem.

As I wrote I already tried with the custom XML, those elements were registered. After a "few" days searching and trying different solutions I found that one wpml table of Sql database was corrupted. I fixed it and then, voilá, all the elements appeared again.