Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 7, 2019 at 12:11 pm

vincentK-10

Hello !

I am trying to: show pictures that do not need to be translated (not working, on every page), translate featured text on the customizr homepage (I can't see them in translations) and trying to figure out why the English content is moved to the right, while it should be centered as in French.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Thanks for your help !

April 7, 2019 at 4:11 pm #3552351

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

show pictures that do not need to be translated (not working, on every page)
- I do not understand this.
- could you please explain this with screenshots for better understanding?

Always ask your every new question in a new ticket to avoid the confusion, please.

When you reply to this ticket I can split this ticket for your other questions.

Let me know.

Regards,
Riffaz.

April 7, 2019 at 4:28 pm #3552433
vincentK-10

Hello and thanks for your help.

I meant that pictures do not show when switching to translated version of the website.

Here are the screenshots.

New threads created by Riffaz and linked to this one are listed below:

https://wpml.org/forums/topic/unable-to-get-the-customizr-string-in-string-translation/

April 9, 2019 at 6:45 am #3563297

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I see these errors: hidden link which comes from your theme.
Please contact your theme support and fix this first because a javascript error can prevent other functions from being executed.
So this need to be fixed first.

Try to disable the WPML for a moment.
Go to your homepage.
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
You will see the same red errors here : hidden link and let me know.

So you can easily understand that this does not come from WPML.

translate featured text on the customizr homepage (I can't see them in translations)
- please follow: https://wpml.org/forums/topic/unable-to-get-the-customizr-string-in-string-translation/

Regards,

April 9, 2019 at 7:33 pm #3570311

vincentK-10

Hi Riffaz,

I have followed your instructions and checked the Chrome console for both scenarios:

- WPML active (original French version), file rttl1.png
- WMPL deactivated, file rttl2.png

I do not get the same errors as yours, but it seems nevertheless that without WPML, all pictures are displayed correctly as it was the case before. I understand though it could come from the theme.

But before I contact the theme authors, I would need to be sure it does not come from WPML, because we both have 2 different errors on the homepage.

April 9, 2019 at 8:22 pm #3570551

vincentK-10

Ok I have updated all extensions and removed the dynamic Youtube homepage video from customizr.

In both French and English there is no more error listed in the console, but still pictures are missing and texts are moved to the right in English. That's clearly a WPML issue.

Please tell me what to do so I can display a correct website ASAP to my customers.

Thanks a lot.

April 10, 2019 at 2:59 pm #3577607

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the explanation.

I am setting the next reply private.
please let me know your site login details to check this closely.

Regards,

April 16, 2019 at 4:04 pm #3623901

vincentK-10

Hi !
I sent the website image with Dupllicator on my first message. Is it possible tonuse it ratjer than using credentials ?

April 18, 2019 at 12:10 pm #3639017

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I could not get that work actually.

Anyhow, this would be much better if we can check this.

So please:
1. go to : hidden link
2. install your theme
3. configure the WPML as you have it on your site. at the last step just press next (sitekey)
4. create only one page with this element.
4. recreate only this issue.
5. let us know how to check step by step.

Regards,

April 25, 2019 at 5:03 am #3678837

vincentK-10

Hi ! I don't have my computer with me at the moment, but I'll follow these steps as soon as possible.

April 25, 2019 at 7:36 am #3679581

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, noted.

I'll keep this ticket open.

Regards,

May 1, 2019 at 5:39 pm #3719165

vincentK-10

Hello,

I will give you newly created credentials. How can I reply privately ?

May 5, 2019 at 4:28 pm #3743541

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The next reply is private.

Regards,

May 7, 2019 at 5:22 pm
May 8, 2019 at 5:26 am #3763901

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the new details.

It keeps loading when I login to your site: hidden link

It's a theme related issue.
So it's better and will be faster if you could follow this : https://wpml.org/forums/topic/missing-2nd-language-content/#post-3639017

Could you please do that?

Regards,

The topic ‘[Closed] Missing 2nd language content’ is closed to new replies.