This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Mihai Apetrei 7 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 19, 2019 at 11:18 am #3378385

yoavL-2

I am trying to: Add a second language Menu.

Link to a page where the issue can be seen:hidden link

I expected to see:(a + add additional language icon - see enclosed image - capture 1a)

Instead, I got: I don have this option (see capture 1b)

March 19, 2019 at 11:23 am #3378445

yoavL-2

please email to - yoav1@hotmail.com thanks 🙂

March 19, 2019 at 4:29 pm #3381405

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

This sounds very weird but it might be due to a couple of reasons. Let's check a few things first.

1. Can you please make sure that if you go to WPML > Support, the information in that table respects the WPML minimum-requirements list here: https://wpml.org/home/minimum-requirements/

2. Can you please make sure that all your plugins, themes and the WordPress Panel are updated and using the latest software version? I can see there are 6 updates available at the top of your screenshot. Make sure that you first create a full backup of the site before you update anything.

3. If nothing works, can you please follow the next steps:

❌ Before proceeding please make a full website backup! ❌

Go to WPML -> Support -> Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

4. If the issue is still happening, can you please try this:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if you were able to find anything.

I will be waiting for your response.

Kind regards,
Mihai Apetrei