This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 3 voices.

Last updated by Bigul 7 months ago.

Assigned support staff: Bigul.

Author Posts
February 6, 2019 at 2:17 pm #3166018

marcov-39

What are you trying to translate?

- a website

What are you seeing? (please include a screenshot)

- The uploaded xliff file does not seem to be properly formed.
Missing or wrong data: target

What's missing or not working for you?

I think the file is properly formed, but there is an error.

Tnx! Martijn

The file is below:

[moved to private reply]

February 7, 2019 at 1:37 pm #3170472

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martijn,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Which tool you are using for translating the exported XLIFF files? Does it happen with all the translation XLIFF files?

We have released a new version of WPML(4.2). It has improvements for Translation management. So please upgrade to the latest version after a full site backup and make sure the issue is existing or not.

If you are still having the issue, please share me the exported XLIFF file and its translated version for further checking. You can share it via Dropbox.

--
Thanks!

Bigul

February 11, 2019 at 4:15 pm #3184070

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martijn,

Thank you for the updates. Please share the following details. Because I would like to discuss the issue with our second tier team.

a) Which Translation tool you are using for translating the XLIFF files(the exported ones)?

b) Does it happen with all the translated XLIFF files?

c) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

February 12, 2019 at 9:15 am #3187426

marcov-39

Dear Bigul, The tool we use is CafeTran I think I tackled the problem. The tool shows empty tags as "<target/>" (and not "<target state="needs-review-translation" state-qualifier="tm-suggestion"></target>")

Replacing the "<target/>" by "<target state="needs-review-translation" state-qualifier="tm-suggestion"></target>" Does not give the original error.

However, when importing the files (in a zip) the server gives a timeout after a few minutes. So it seems that WPML does process them all at once. How can I prevent this (I already tried two batches, but that does still give the error)

tnx, Martijn

February 12, 2019 at 12:17 pm #3188417

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It is happening after upgrading to WPML 4.2 also, am I right?

Please share with me the WordPress debug.log (not WPML debug information) for more details. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

February 12, 2019 at 3:27 pm #3189505

marcov-39

Hi,

Hereby the log as requested (pastebin did not accept the size)

hidden link

Grtz, Martijn

February 12, 2019 at 6:34 pm #3190421

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martijn,

Thank you for the *debug.log* details. It is showing some errors related to WPML. We have released a new version of WPML(4.2.1). So please upgrade to the latest version after a full site backup. Then make sure you are still having the issue or not.

If you are still having the issue, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

February 14, 2019 at 12:59 pm #3199817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martijn,

Thank you for the login information. Please upgrade to the latest version of WPML String Translation, Translation Management and WooComemrce Multilingual after a backup. Because now you have only upgraded the WPML Core plugin. Please check the attached images for more details.

If you are still having the issue, please allow me to do the following for tracking the issues.

a) Please give me permission to add the user shared with me as a Translation Manager

b) Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 18, 2019 at 11:14 am #3211613

marcov-39

Dear Bigul,

The issue remains the same. I have a 500 notice after waiting for e few minutes. Probably a timeout.

" Please give me permission to add the user shared with me as a Translation Manager"
My colleague helped you, can you let me know what user your are referring to? (username?)

Tnx, Martijn

February 18, 2019 at 1:40 pm #3212477

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul is off today, so I am taking care of this ticket, hope that's ok. 🙂

The username is everybody1971.

I have a 500 notice after waiting for e few minutes. Probably a timeout.

Is this 500 error happening when trying to upload the xliff file?

Also, to further debug this issue, we would need to replicate your site on my localhost and perform further debugging, so could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Thanks

February 20, 2019 at 6:38 am #3220066

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have marked the previous reply as private.

While I am uploading the xliff file, the following message is shown:

The translation job (9004111222525076) doesn't belong to you.

So, could you please provide me access to the user which creates this issue? You can edit your previous private reply to send the details.

Look forward to your reply.

Thanks

February 20, 2019 at 1:52 pm #3222097

marcov-39

Hi, I've added the info at the bottom of the private message before. Can you also change the first message in this feed to private? (the one with all the code) Tnx! Martijn

February 21, 2019 at 11:38 am #3227049

marcov-39

Hi, Thank you for hiding the code. Is there any news on the issue itself?

Tnx!

Martijn

February 21, 2019 at 12:37 pm #3227398

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that issue, it seems like there are some fatal error happening on the site while updating the jobs, to further debug this issue, I would need to replicate your site on my localhost and escalate it to 2nd tiers if necessary.

So, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Look forward to your reply.

Thanks

February 25, 2019 at 8:35 am #3238360

marcov-39

Dear All,

I've created a DB and files backup. You can find those via the earlier shared drive folder.

With kind regards, Martijn Wijnberg

The topic ‘[Closed] Missing or wrong data: target’ is closed to new replies.