This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 5 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
May 8, 2019 at 2:49 pm #3767909

laurentW-2

Tell us what you are trying to do?

We are trying to translate our product pages from french to spanish

We just try with this french product page : hidden link

To spanish : hidden link

We do not have same blocks and same contents in the editor to make a complete traduction of all the good fields in french.

Can you help us to resolve it?

Thanks,

Regards

May 8, 2019 at 7:08 pm #3770339

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @laurentw-2, welcome to the WPML support Forum!

Probably your theme or some plugin is generating elements that are not registered for translation in wpml-config.xml. In this case it may be necessary to register these elements: https://wpml.org/documentation/support/language-configuration-files/

Could you please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Another option is to translate using the manual editor:
- Go to the edit screen of the page (original language).
- Turn off the "Use WPML's Translation Editor" on the right sidebar
- Select your editor preferences and save
- Edit the translation

Please let me know if it worked for you.

All the best,
Diego

May 9, 2019 at 7:29 am #3773695

laurentW-2

Hi Diego,

First thanks for your quick answer, here has you ask me I send you our debug information

Regards

May 9, 2019 at 6:51 pm #3778903

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I noticed that you are using the first pixel theme, which is not at our compatible themes list: https://wpml.org/documentation/theme-compatibility - the theme may be adding extra elements that are not registered for translation.

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you. If so, please send us clear instructions on how to see/reproduce the issue.

Kind regards,
Diego

The topic ‘[Closed] Missing parts of text fields’ is closed to new replies.