This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Noman 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
September 3, 2019 at 9:42 am #4503045

przemyslawM-5

Hi,

i have problem with blog on my installation. For some reason any new posts after number 24 doesn't show up on post list: hidden link, there suppose to be another post here on list(hidden link) but it doesn't show up at all.

I have checked not to translate posts/categories from blog but WPML ignores that option for some reason(check attachments). It's like that from last update i belive.

The issue is with WPML itself, because if i deactivate plugin, then post show up there normally.

How do i deal with that?

September 3, 2019 at 12:23 pm #4504381

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

=== Please backup your database and website ===

I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

September 3, 2019 at 4:08 pm #4506161

przemyslawM-5

I have added the code(didn't really had any problems regarding memory), but problem persists.

1. I have tried deactivating all plugins and it's only fixed once WPML is deactivated.
2. I've switched to Twenty Sixteen, still same issue.

September 4, 2019 at 10:01 am #4509899

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 5, 2019 at 5:50 am #4515535

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and followed below steps:
- Changed ‘Not Translatable’ option to ‘Translatable - use translation if available or fallback to default language’ option from WPML >> Settings >> Multilingual Content Setup > Post Types Translation.
- Pressed ‘Save’ button.
- Then again selected ‘Not Translatable’ option and issue is gone as you can see in the attached screenshot.

Could you please check and confirm?

Thank you

September 5, 2019 at 10:09 am #4518243
przemyslawM-5

It is, thank you! Any idea why it was like that in first place?

Other thing - i don't want post categories to be translable, i want to have blog only in one language but there's 2 other categories, which i can't remove. Those two unnecessary categories will be indexed - i don't want that. How do i deal with that?

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/i-dont-want-post-categories-to-be-translable/

September 5, 2019 at 4:00 pm #4520659

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

It seems ‘Not Translatable’ options had not saved correctly that’s why issue arises. I have created a new ticket to handle it separately. Here is the link to the new ticket: https://wpml.org/forums/topic/i-dont-want-post-categories-to-be-translable/

Thank you for your cooperation and patience.