This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by christineP-7 2 weeks, 6 days ago.

Assigned support staff: Bruno.

Author Posts
September 19, 2019 at 8:03 am

christineP-7

Hello,

This message is displayed since the plugin update : Missing records in language tables

I have already done the following:

Then, go to WPML -> Support -> Troubleshooting.

Look for \'Clean up\' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

I think I also did the right thing for the WPML menu and language selector options

On my home page, I can only choose the current language in the language selector.
I posted the HTML source of the rendered page and search on "hreflan
I send you a screen frame

The problem happened after the update

Thank you

September 19, 2019 at 8:11 am
September 19, 2019 at 11:14 pm #4608401

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. When I try to access your site using the credentials you posted above, but this message appears: ERREUR : identifiant non valide. Mot de passe oublié ?

As the site still seems to be under development, I could not access the homepage either. Could you please check? Your next message will be private.

Thanks.

September 20, 2019 at 7:17 am
September 21, 2019 at 4:46 am #4615389

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I noticed that although you are using it to display the directory even in the default language, you have not yet defined a file or page to be the root page. You must set a page as root page. You can see more details in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Also, I noticed that there is a redirect being done when I access the page in the secondary language. Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

September 25, 2019 at 11:08 am #4638075

christineP-7

Hello, yes you can install Duplicator and do your tests
Thank you

September 25, 2019 at 5:16 pm #4641419

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I fixed your site. Could you please check if the error message that was being displayed has been fixed?

About the homepage not appearing in English, I noticed that the "Home" page in English is still being translated and is not yet being displayed. If the problem persists even after finishing page translation, may I kindly ask you please to open a new ticket for your new question? According to our guidelines, only one issue per topic is allowed. Also, this will also help other users with similar problems find solutions when searching the forum.

Thank you.

September 25, 2019 at 5:38 pm #4641517

christineP-7

the message is no longer displayed, but I still can not see the different language selectors on my home page, only the current language is displayed
thank you

September 25, 2019 at 5:55 pm #4641591

christineP-7

My issue is resolved now. Thank you!