Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 8.24 hours from now. Thank you for your understanding.

This topic contains 26 replies, has 2 voices.

Last updated by Mihai Apetrei 4 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 20, 2022 at 8:29 pm #11058869

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Can you also please go here (hidden link), select "pay as you go" and set up your automatic translation account, so that I can assign some credits and test a couple of things? The account is free up to 2000 credits per month and what I will use will be test credits so no charges will happen on your side.

Please let me know once that's ready.

Thanks.

Mihai

April 22, 2022 at 9:10 am #11072121

Kristof

I have activated the credits.

Today I noticed 2 more pages where the translation editor misses text for translation, one is "Bakken en uitkuilapparaten" under parent "Fliegl Agrocenter". The intro and the button you see here hidden link don't show up in the translation editor although the editor says it's 100% complete. The Dutch text is just copied over to French hidden link

Same for "Balenklemmen" under the same parent page, intro and button at hidden link again missing in the translation editor and Dutch text shows up in French page hidden link

April 22, 2022 at 10:25 am #11072919

Kristof

I don't know it the issue was fixed automatically of if you fixed it, but the 2 pages I mentioned in the last post, now do show ALL translatable strings, so including the intro and the button.

April 26, 2022 at 9:58 am #11095315

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Can you please extend the auto-login URL?

Please let me know once that's ready.

Thank you.

Mihai

April 26, 2022 at 10:43 am #11095783

Kristof

it has been extended with a month

April 28, 2022 at 1:34 pm #11115195

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there. I am back.

It has been a long time required to debug this. Also, the staging server loads very slowly for me and this made things take even longer.

It seems that Elementor has a new type of container that WPML is not compatible with yet.

So, the issue was this:

- the first heading that WPML was able to see was added inside 2 containers: the main one for the whole first section (the one with the picture on the left and with the heading+form on the right)

- while the second heading was wrapped in only one single container (the main one of that section)

To help WPML see that second heading, we need to create an extra container that you can drag above the second header and then drag the second header inside that new container.

After that, we need to save the page and then go to the translation page where you should now see the second heading.

I'm also attaching a screenshot below so that you can see the icon for the container that shows up when you are in Elementor (default language) and hover over the first heading, which was not showing up when you hovered over the second heading (I added it).

You will see that I added some extra screenshots so that you can see how the correct content was now showing up in the ATE editor.

However, something went wrong with the server and now the contact page translation shows up as empty - so I will need you to please restore the staging to a recent backup and let me know when that's ready so that I can reimplement the work.

I will be waiting for your response.

Mihai

Screenshot 2022-04-28 at 15.41.59.png
Screenshot 2022-04-28 at 15.48.08.png
Screenshot 2022-04-28 at 15.51.05.png
Screenshot 2022-04-28 at 14.45.01.png
May 2, 2022 at 2:17 pm #11134035

Kristof

to which date would you want me to restore a backup?

May 3, 2022 at 9:06 pm #11144619

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Let's try a restore for 27 April.

Please let me know once that's ready.

Thank you.

Mihai

May 4, 2022 at 7:14 am #11146925

Kristof

Hi,
unfortunately, I've already spent hours in the site so I can't restore any backup. I have fixed the Contact page myself.

Would you be willing to address this issue to the developers so that the strings can also be found/translated when they are directly in the parent container (so no need for nested containers). This new Elementor experiment will soon hit the plugin core which means that from that moment on, all new Elementor sites will by default use the new Container setup and few people will be aware that WPML needs nested containers in order to work, so I think this might need some priority at WPML.

May 4, 2022 at 6:08 pm #11153839

Kristof

Could you have a look at the Home page also please? I made sure each translateable item is in at least 2 containers, but there is A LOT of text missing for the French translation, actually all text is missing. The only thing I get to translate are a few icons??

Screenshot_6.jpg
May 4, 2022 at 6:43 pm #11153965

Kristof

This might seem fixed with the latest update from May 2. Will need to do some more testing with non-nested containers, so where the Text/Title is directly under the main Container.

May 6, 2022 at 12:22 pm #11167247

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

I am happy to hear that this looks fixed now.

The developers were working already on a fix for the Elementor issue but the current workaround was the one that I shared with you.

Please test and see if the issue is now gone and let me know.

Thank you.

Mihai