Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by annikaN-2 5 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 2, 2020 at 11:50 am #6043483

annikaN-2

Tell us what you are trying to do? Translate and it work what you told me (chatt with Raja Mohammed earlier today) about Auto generate for some strings but not for all. I attached some photos
6.png I have translated in the top menu the Free shipping etc but not show on the live site
4-5.png This strings on this screenshots are not auto generated even if I tried 100 times
You need help? Call customer service at +30 22810 89058
Subscripe to our news...
All 3 examples are in Avada Theme option if that have something to do with it but the first is in string translater but just want work.

Is there any documentation that you are following? Got help from you

Is there a similar example that we can see?

What is the link to your site? hidden link

May 2, 2020 at 11:53 am #6043551

annikaN-2

Sorry forgot the password: Thollans

May 2, 2020 at 11:57 am #6043557

annikaN-2

Maybe this can be useful which relate to the screenshot before 6.png

May 4, 2020 at 11:02 am #6052761

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, thank you very much for your patience and sorry to have you waiting - there is a very full ticket queue at the moment and it takes us a bit more than usual to answer tickets.

Now, regarding your request, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 4, 2020 at 12:59 pm #6053477

annikaN-2

Sorry but I just remembered another thing, I set the language switcher to be the last in top menu but this also not working. I worked for years with your plugin and never had so many faults so maybe something is really wrong

Thanks,
Annika

May 4, 2020 at 4:42 pm #6055073

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials. Also, thank you for the extra input.

I can confirm that they work.

I am spending more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

May 5, 2020 at 3:44 am #6057441

annikaN-2

Thank you and I await answer from you then. I hope it's ok that I work on the website because I need to have it ready for next week.

Thanks,
Annika

May 5, 2020 at 6:55 pm #6064491

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Annika and thank you very much for your amazing patience.

1. Regarding the strings in the top bar, it seems that we needed to check a different admin text string for translating those words because the ones we used them were for the main theme while what you have active on the site is a child theme.

I found that for you (I will attach a screenshot) and I already translated it. You will also see it in WPML > String Translation if you search for the words.

2. I followed the same procedure to find the following strings (they are now showing in WPML > String Translation and are ready to be translated):

- You need help? Call customer service at +30 22810 89058
- E-mail shop@scarpamagazino.com

Regarding the "subscribe to our newsletter" string, I went here (hidden link) and wrote this short lines of code:

<wpml-config>
    <admin-texts>
        <key name="mailchimp-woocommerce">
            <key name="newsletter_label" /></key>
    </admin-texts>
</wpml-config>

That made the right string show up in WPML > String Translation and I already translated it for you.

I think our problems are solved and things can properly be translated now 🙂

Please confirm.

Kind regards,
Mihai

May 6, 2020 at 5:15 am #6066873

annikaN-2

Thank you,
I will check this later today because need to go out for some work
Annika

May 6, 2020 at 9:19 pm #6074725

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

That's great, Annika.

Please let me know how that goes.

My work should have solved the issues that you mentioned 🙂

Kind regards,
Mihai

May 7, 2020 at 4:24 am #6076407

annikaN-2

Thank you now I got the Free shipping fixed but still some issues, I attach some screen prints

1 10.png I find "Order under 80€ - Shipping" and translated it but doesn't show live? Under the "cost:" I don't find in the sting translation?

2 12.png I found the "You need help?..." text but not either this show live?

I wonder if it's some general problem because under all this years using your plugin I haven't run in to so much problems. Also have another ticket going on with your support about greek category urls that doesn't work???

Thank you,
Annika

May 7, 2020 at 3:45 pm #6082167

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and welcome back.

What you might be seeing is a cached version.

From what I can see, if I load the site from an incognito window or from another browser, the strings look correctly (I'm attaching 2 screenshots).

Please confirm that this works for you, too.

Kind regards,
Mihai

May 7, 2020 at 4:04 pm #6082337

annikaN-2

It seems to be ok but now the Subscribe to our newsletter is not translated see attached screenshot and the greek is terrible because to long word but what to do

Have a nice evening,
Annika

May 7, 2020 at 4:26 pm #6082521

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

That string was set to "Translation needs update".

I will attach some screenshots.

I resaved it (published it now) and it works without issues.

Please confirm.

Kind regards,
Mihai

May 8, 2020 at 3:14 am #6085361

annikaN-2

Thank you very much for your patient, stay safe,
Annika