This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bruno 3 weeks, 1 day ago.

Assigned support staff: Bruno.

Author Posts
September 5, 2019 at 6:56 pm #4521655

Ron

I am trying to: Clean up the connections of the translated pages to the English Version.

1) On the English, French and German home page it is connected to the Italian version
2) On the Spanish home page, there is no drop down

What I want to be able to do is tell each translated page to connect to its proper English version.

In a previous support ticket I was told to set the drop down to "This is a translation of" None and then reconnect it to the proper English page. However, when I do that the system always ends up pointing to the Italian home page.

For instance WPML allows me to edit

hidden link

to connect with

hidden link

I also want it to connect with

hidden link

hidden link

hidden link

Currently the English, German and French translated pages point to the Italian version. In the Spanish version the drop down is missing altogether.

September 5, 2019 at 11:26 pm #4522129

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. When you created these pages in Spanish, did you translate this page or did you create this page directly in the secondary language (Spanish)?

Typically, this option should only be displayed if the page is actually a translation. That is, this option is not displayed in the language in which the page was created (if you create a Spanish page directly, this option should not be displayed, for example).

Thank you.

September 5, 2019 at 11:44 pm #4522141

Ron

It was created using the WPML system. Also, why do the other pages only connect to the Italian version?

September 6, 2019 at 11:10 pm #4527501

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

To be able to check what you are reporting, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 11, 2019 at 1:44 am #4549397

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. When I try to access your site using the credentials you posted above, this message appears: ERROR: The username or password you entered is incorrect. Lost your password?

Could you please check? If necessary you can edit your private message above, which should be highlighted.

Thank you.

September 11, 2019 at 3:30 pm #4554843

Ron

I have updated your access

September 11, 2019 at 11:58 pm #4556793

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I tried to create a copy of your site using Duplicator, but it seems that your site is no longer responding. I will attach a picture for you to see.

Perhaps the problem was due to the size of the site - even filtering out the files in the upload folder, the site was over 500 MB in size.

Could you please check again?

Thank you.

September 12, 2019 at 3:07 pm #4562243

Ron

I will create a test site that you can directly access and make whatever tests you need

September 13, 2019 at 3:57 pm #4569941

Ron

The new test site is live. Please see the new login info

September 13, 2019 at 10:46 pm #4570951

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I will test your site and see what may be happening and why these "this is a translation.." options are not consistent. Soon I will contact you.

Thanks.

September 17, 2019 at 12:22 am #4584559

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I tested your site and it looks like these pages you posted above corrupted the WPML records. This may have happened to some site migration.

Inside the database, in the "wp_icl_translations" table if you get the "trid" 105 (which is the "About" page trid), you will see that the French and English pages are being treated as default pages. I will attach a picture for you to see.

Changing the French language to be the "source language" of English, the pages are connected again. I will attach a picture for you to see.

Then just disconnect the page and follow the steps you were doing before. This may also have happened if you changed this option to disconnect the page, but for some reason, the new trid was not created.

As this is a bit more technical, please let me know if I want you to change it directly on your site. I will be happy to help.

Thank you.

September 17, 2019 at 2:45 pm #4589319

Ron

Hi, I am confused by this solution. "Changing the French language to be the "source language" of English, the pages are connected again. I will attach a picture for you to see." Does not make any sense to me.

September 21, 2019 at 4:55 am #4615395

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Explaining in a simpler way, when a page is created, WPML creates a record in the database. When a translation is made, this translation page uses "source_language_code" to identify which is the original page and which is the translation.

Note in the first screenshot I posted above. Using English as the primary language, source_language_code appears as "null" (is correct). The other languages should be the English translation. That is, the "source_language_code" must have the "en".

The problem is precisely because the page in French is also being identified as a primary language (note the null at the first screenshot). Making the change I suggested above will fix the problem.

As this is quite technical, please let me know if you want me to make this change for you. I will be happy to help you fix this issue.

Thanks.

The topic ‘[Closed] Missing "This is a translation of" drop down in some cases’ is closed to new replies.