Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by ajansF 2 weeks, 3 days ago.

Assigned support staff: Riffaz.

Author Posts
November 6, 2019 at 6:38 pm #4900935

ajansF

Hi;
I get mixed content error in admin panel. Therefore chrome gives "Insecure Content Blocked" error.

When I open at the console, I saw that all the mixed content problem was caused by wpml :/

so i tried to;

1. URLs in wp settings start with https
2. I cleared the cache via WPML> Support> Troubleshooting
3. With the help of better search and replace, I changed all protocols in the database to "https"
4. i purged cache on cloudflare

how can i fix this?

November 7, 2019 at 5:00 am #4902739

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This means still you have HTTP links in your site.
Using the better search replace plugin please search for 'HTTP' then change it https
Let me know how it goes.

Regards,
Riffaz.

November 7, 2019 at 5:42 pm #4909033

ajansF

Hi Riffaz;

I did replace. There are screenshots in the first post attachments.

November 10, 2019 at 1:08 pm #4920417

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details.
The next reply is private.

Regards,

November 11, 2019 at 11:42 am #4924547

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

When I ran a Dry run I see this: hidden link
So there are 187 HTTP links.
please replace them.
do not forget to select all the tables here: hidden link
scroll down inside that column and select them all. then search and replace.

Regards,

November 19, 2019 at 4:54 pm #4974477

ajansF

Are you sure this method is correct?

if I replace it this way, doesn't the following problem occur in URLs starting with https?

hidden link... => hidden link... (correctly replace)
hidden link... => hidden link... (faulty replace)

so i can't find results when I search "hidden link" => "hidden link" because before I did this replace.