This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 23, 2019 at 1:30 pm #4073067

John

Hi,

I have problems with the backend languages in elementor recently. I have set the language of the back-end to english. Lately languages get mixed up, to be honest i don't know since when.
Anyway the elementor back-end languages switches to the language of the page, (what it is not supposed to do, if i am correct) but not completely. I have attached screenshots to demonstrate:
english and dutch: an english page but with a dutch elementor back-end
french: french page with obviously french elementor back end, but when a section or element is selected you get:
french and dutch: a mixture, french texts and dutch texts (geavanceerd,verticale uitlijning, horizontale uitlijning are dutch words).

John

June 24, 2019 at 12:44 pm #4077287

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I suspect that when WPML scanned Elementor or other associated plugins it might assigned the strings to the wrong language. In this case I would like to ask you to follow this steps:\
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- Go to WPML -> String Translation -> Select and delete the strings from Elementor (https://wpml.org/documentation/getting-started-guide/string-translation/#auto-register-fe)
- Go to WPML -> Theme and plugins localization -> Scan Elementor plugin.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.
Could you tell me the result of this steps?

Kind regards,
Carlos

June 24, 2019 at 1:38 pm #4077535

John

Sorry, these steps did not solve the issue.
However i checked into my testsite with older versions of both elementor and WPML and there the mixing did not occur. Except Elementor switched to dutch (being my WPML default language) from english (being my WP language)
Versions were elementor: 2.5.16 and elementor pro 2.5.8 and WPML CMS 4.2.7.1 WPML stringtranslation 2.10.5.1

Best,
John

June 24, 2019 at 1:49 pm #4077659

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi John,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 25, 2019 at 9:03 am #4082485

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I consulted our specialists about this issue and I suspect this might be caused by a bug or an interacction issue with a third party functionality. To isolate the cause of the issue I created a test site with a fresh new WordPress install and WPML plugins installed and setup.

I would like to ask you to install the plugins and create the minimum information to reproduce the issue in this test site. You can access to the test site using this link: hidden link

Please let me know if you were able to reproduce the issue.
Regards,
Carlos

June 25, 2019 at 9:11 am #4082543

John

I am sorry Carlos, but i am afraid this route is not viable. A large number of the plugins i use, are paid plugins with a license for one site only. I can not install these plugins at the same time as having them active on my site.

Best,
John

June 25, 2019 at 12:46 pm #4084699

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi John,
Thank you for your message.

I consulted our specialists and we weren't able to reproduce the issue with the mixed languages in the Elementor's backend. However I can confirm that Elementor will always load the language you are translating into, which means that it won't load the backend language you set in your user's profile, instead it will load English if you are editing a post/page in English, French if you are editing a post/page in French, etc.

In this scenario I would like to ask you to create a new test page and edit it with Elementor. If the issue persists (the mixed languages) then deactivate any plugin that could be creating custom elements for Elementor and double check if the issue persists.

Looking forward to your message.
Regards,
Carlos

June 25, 2019 at 2:14 pm #4085377

John

Hi Carlos,

It was a search because it turned out that two plugins were responsible: both "Envato Elements" and "Schema & structured data for WP" resulted in languages getting mixed up.
I can do without "Envato Elements" being active all the time, however i can not do without the "Schema & structured data for WP" plugin. So i guess i will need to live with this.

Thanks,
John

June 26, 2019 at 10:21 am #4091413

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi John,
Thank you very much for your feedback.

In this case I recommend you to contact the plugin's authors and let them know about this issue. They should be able to give you a final solution for this issue.

Regards,
Carlos