Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by paulL-22 1 year ago.

Assigned support staff: Bigul.

Author Posts
January 31, 2019 at 11:22 pm

paulL-22

I am trying to:translate next and previous

Link to a page where the issue can be seen:

I expected to see: translation in each language

Instead, I got:mixed up language

February 1, 2019 at 1:43 pm #3151823

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

February 2, 2019 at 12:41 am #3153638

paulL-22

Hi Bigul,
I did everything you told me to do but I am still having the same issues.

Thanks.

February 4, 2019 at 6:00 am #3156396

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. This may be happening because of the compatibility conflicts. Therefore please try the following steps after a full site backup and check the issue is existing or not.

1) Please deactivate SG Optimizer plugin
2) Clear all types of caches include the server-side cache
3) Then check the issue is existing or not
4) If you are still having the issue, please switch to *Saved* parent theme or default 2017 theme(for few minutes for testing) and make sure the issue is existing or not

--
Thanks!

Bigul

February 4, 2019 at 3:14 pm #3158423

paulL-22

Hi Bigul,
I did but not working. Could you please escalate those issues to the compatibility team so they can fix them. I told you that because 2 weeks ago, I have a lot of issues like that, they fix them by changing some codes i the theme files.

Thanks.

February 4, 2019 at 5:56 pm #3159000

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 4, 2019 at 11:17 pm #3159589

paulL-22

Hi Bigul,
You can do it.
Thanks.

February 5, 2019 at 4:00 pm #3162767

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have activated the Duplicator plugin but the Duplicator menu is not showing in the backend. The result is the same after several tries.

Please make sure you are using any server-side cache. If so, please clear it and check.

--
Thanks!

Bigul

February 5, 2019 at 5:56 pm #3163222

paulL-22

Hi Bigul,
Deactivate the SG Optimizer plugin, the duplicator will show up. Then re-activate the SG Optimizer plugin.

Thanks.

February 6, 2019 at 7:19 am #3164375

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can make a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

February 7, 2019 at 4:18 pm #3171276

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the issue is existing in a fresh and minimal setup. Therefore I am escalating the ticket to our compatibility team for further debugging.

We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

February 8, 2019 at 9:14 am #3173793

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, our compatibility team has found the code making the conflict. It works for us after the following steps. Please try it after a full site backup and let me know your feedback.

1) Upgrade to the latest version of WPML(4.2)
2) Visit wp-content/themes/saved/framework/includes/
3) Open *people.php* file for edit and scroll down to lines 97-98
4) Make the following change in the code

From

add_filter( 'get_previous_post_where', 'ctfw_previous_post_where' );
add_filter( 'get_next_post_where', 'ctfw_next_post_where' );

To

add_filter( 'get_previous_post_where', 'ctfw_previous_post_where', 9 );
add_filter( 'get_next_post_where', 'ctfw_next_post_where', 9 );

5) Save the changes and visit people posts in the frontend

Please update your theme provider about this fix. So we can keep it compatible in the upcoming version of the theme.

--
Thanks!

Bigul

February 8, 2019 at 2:17 pm #3175601

paulL-22

Hi Bigul,
For people feature, it's now working fine. Thanks.
I am waiting for a fix for the other issues in the same ticket.

Thanks.

February 8, 2019 at 6:17 pm #3176559

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please share more details about the following for a better understanding. So we can make sure we will not miss any issues.

I am waiting for a fix for the other issues in the same ticket.

--
Thanks!

Bigul

February 9, 2019 at 3:00 pm #3178517
paulL-22

Hi Bigul,
The website has only 3 sermons and 3 posts. From the original language which is English, we translate them to French. The issue is in the count, you can see that in the files I sent to you. when you are in English or french and you click on "month" or "mois", the count shows 6 instead of 3. In English or in French it should display 3 posts or 3 sermons not 6. That's the issue.

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-issues-with-post-count/