This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 3 voices.

Last updated by Itamar 2 months ago.

Assigned support staff: Itamar.

Author Posts
August 18, 2019 at 3:23 pm #4412463

julianB-16

Tell us what you are trying to do?
We've been building the new website with Elementor (free version) on Hestia Pro Theme, and after installing WMPL the responsive version started to look weird. It's suddenly too narrow and not responsive any more.
I'm sorry I couldn't provide with more information. I'm willing to help if necessary.

Is there any documentation that you are following?
https://wpml.org/faq/install-wpml/#first-install
https://wpml.org/documentation/getting-started-guide/
https://wpml.org/documentation/plugins-compatibility/elementor/

Is there a similar example that we can see?

What is the link to your site?
hidden link

August 18, 2019 at 4:17 pm #4412501

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporarily.

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

August 19, 2019 at 2:49 pm #4416957

julianB-16

Thanks Noman for your reply.

I've followed your instructions, but yet the website is still broken.

1.- I've changed the website’s WP Memory Limit.
2.- I've cleaned the cachés, and disabled WP Super Caché.
3.- I've deactivated all plugins, but the site would remain broken.
4.- I've changed the theme to Hestia free version and this turned out fine. However, I've purchased Hestia Pro theme because of the features provided and bought WPML Multilingual CMS because it was supposed to be compatible, and was also supposed to work with all Hestia PRO features.
5.- As it isn't a very big site we even tried building a new site from scratch to check this out, installing all plugins before starting building pages. Before we used WPML pages seemed to be fine. When we started translating the pages, the site started to look odd. Besides, Front Page Sections, eventhough they were published, were not visible, from the very beginning, before or after using WPML.

What would you suggest?

Thanks a lot!

August 20, 2019 at 2:40 pm #4424517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for following Noman's suggestions.

Noman is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

Indeed the Hestia Pro theme is officially compatible with WPML.
https://wpml.org/theme/hestia-pro/
But I can also see that it has not been tested for more than a year and a half.
So there might have been some changes in the theme that were not adjusted to WPML.

To continue debugging this issue, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Hestia Pro theme and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the theme.

Thanks,
Itamar.

The topic ‘[Closed] Mobile Site Messed Up After Installing WMPL on site built w/Hestia Pro Elementor’ is closed to new replies.