This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Laura 8 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
February 8, 2019 at 10:29 am #3174459

paulM-47

I am trying to: I am trying to translate the Features option of the Modality theme and some strings don't show up in the admin texts panel. There are 8 Features and feature 5, 6, and 7 are missing.

Link to a page where the issue can be seen: hidden link

I expected to see: Only english text and headlines

Instead, I got: A mix of english and german

February 9, 2019 at 5:38 pm #3178637

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

If you couldn't find those string in String Translation or in the strings admin page, you can add manually in the xml-config file in WPML -> Settings -> Custom XML Configuration

See our documentation: https://wpml.org/documentation/support/language-configuration-files/

Let me know if this helps you or if you need further assistance.

February 11, 2019 at 12:27 pm #3182817

paulM-47

Hello,

I have already tried adding all the missing strings to the XML file and it makes no difference, they still don't show up on the String stranslation dashboard.

February 13, 2019 at 7:55 am #3192402

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

Could you send your WPML debug information? You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

Could you also provide credentials so I can take a better look? I'll enable a private reply.

February 14, 2019 at 1:30 pm #3200021

paulM-47

In order to create an account and to send you 23 pages of debug-informations I need an email address from you. Can you please provide these to me?

February 14, 2019 at 1:33 pm #3200029

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

there is a box when you reply to tickets where to copy debug information, even if you sent them by mail or copying them here or somewhere else they wouldn't be readable.

February 14, 2019 at 1:47 pm #3200101

paulM-47

[credentials removed]

February 14, 2019 at 1:48 pm #3200103

paulM-47

I am not ableto send you the debug informations, because i get this:

The debug information is not valid.

February 14, 2019 at 3:28 pm #3200602

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I removed the credentials from your previous post because they were exposed in the public forum. Please don't add any private info unless we enable a private answer. As a further precaution, I'd suggest to change them.

I'll enable a private answer for credentials

February 15, 2019 at 9:00 am #3203582

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I see that the WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Since the strings are correctly translated, this could be enough to solve the issue.

The topic ‘[Closed] Modality theme strings not found by WPML’ is closed to new replies.