Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client was using the Muffin Builder with Betheme and encountered an issue where only the title of the page was being translated, and the builder blocks were not being copied to other languages.

Solution:
We recommended checking the compatibility settings for Muffin Builder as outlined in our documentation. Specifically, we advised the client to:
1. Visit the Betheme options page (https://turkkad.org/wp-admin/admin.php?page=be-options#advanced&advanced) and adjust the settings to "Serialized | Readable format, required by some plugins" as per the WPML documentation.
2. If content was created with Muffin Builder before setting up WPML, update the pages or posts to make their content available for translation.
3. Make a small edit to the homepage or any other page in the default language, then save the page.
4. After making a small change, go to the translation page and the content should be available for translation.

We also ensured that the client updated all plugins and the Betheme theme to the latest versions. Additionally, we requested the client's approval to duplicate the site using the "Duplicator" plugin for further debugging in a local testing environment.

After following these steps, the issue was resolved, and the content became available for translation.

If this solution doesn't look relevant to your issue, please don't hesitate to open a new support ticket with us.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months, 2 weeks ago.

Assisted by: Mihai Apetrei.

Author Posts
November 20, 2023 at 7:34 pm #14880571

kerimE

Hi,

I am using muffin builder as betheme. It just translates the title of the page. It does not copy builder blocks to other language. What should I do?

Regards.

November 20, 2023 at 11:05 pm #14881115

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

Before this ticket gets assigned to one of my colleagues, I will try to help.

Can you please let me know if you had the chance to go over the amazing documentation that we have available at the URL below:
https://wpml.org/documentation/theme-compatibility/create-multilingual-wordpress-websites-using-betheme-and-wpml/

I think you might find that helpful and it might help you get things working as expected.

Please let us know how that goes.

Mihai Apetrei

November 21, 2023 at 8:26 am #14882915

kerimE

I read the article and it was not solved. I updated the theme and switched to bebuilder. I read the article below and checked. Already the codes are this way I think they have updated it. How can I solve it?

https://wpml.org/errata/betheme-betheme-bebuilder-live-editor-design-is-not-copy-to-translations/

November 21, 2023 at 10:29 pm #14891675

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

1. Can you give me an example of a page URL where this issue is happening?

2. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

November 24, 2023 at 8:38 am #14914103

kerimE

Any progress?

November 24, 2023 at 12:52 pm #14917383

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

I hope that by the end of today, I will be able to come back with more updates.

The queue has been super full these days so it takes a bit more time than usual to get back to customers.

Thank you for your amazing patience though! It is very helpful in the debugging process.

I will be back.

Mihai

November 25, 2023 at 10:03 am #14921571

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

I was able to find out that the steps in the documentation were not followed completely, there are still a couple of things that need changes.

Please take a look at the first section in the documentation here:
https://wpml.org/documentation/theme-compatibility/create-multilingual-wordpress-websites-using-betheme-and-wpml/#ensuring-compatibility-with-muffin-builder

What is recommended is to go on this page here (hidden link) and change the settings according to the documentation.

I am attaching a screenshot - at the moment, the data storage is set to "Encoded" instead of "Serialized | Readable format, required by some plugins".

If you have already created some content with Muffin Builder before setting up WPML, you may need to Update such pages or posts to make their content available for translation.

So, practically, after you set the correct setting, you can go to the homepage's default language edit page in the backend (hidden link), make a small edit, and then save the page.

After you make a small change in that page (or any other page), you can go to the translation again (in our case this is the homepage translation - hidden link) and you should start seeing the content available for translate.

Please let me know how that goes if you want to handle this or let me know if you want me to handle this for you, I wouldn't want to make changes on your site without your approval and a confirmation that you already have a website backup.

I will be waiting for your response.

Mihai

Screenshot 2023-11-25 at 11.54.53.png
Screenshot 2023-11-25 at 11.54.45.png
November 25, 2023 at 5:39 pm #14923031

kerimE

I actually did this setting but it didn't work so I undid it. I redid this setting as you said, tried again and it didn't work. Can you try to translate it into English from the following page?

hidden link

November 27, 2023 at 2:20 pm #14931011

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Thank you for the update!

Can you please create a full website backup and then update all the plugins + the "Betheme" versions here:
hidden link

Please let me know once that's ready.

Thank you!

Mihai

November 28, 2023 at 11:06 am #14938013

kerimE

I took a backup and updated the plugins, but no change.

November 29, 2023 at 4:00 pm #14953531

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Yes, no worries. I just wanted to know that we have the latest versions there and that everything else still works fine after we update to the latest version.

To further debug the problem I’d like to replicate your site locally.

I will need your written approval to be able to duplicate your site using a plugin called "Duplicator" and test your site on a testing environment so can you please let me know if this is ok with you?

After we find a solution for this, the duplicated site will be deleted.

Also, please make sure that a full website backup has been created before answering.

Please let me know if that's ok with you.

Thank you!

Mihai

December 1, 2023 at 11:03 am #14971595

kerimE

Yes. You can do it. Thank you very much.

December 2, 2023 at 10:24 pm #14978857

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Thank you for the confirmation.

I will keep you up to date with the progress as soon as I have updates.

I'm leaving the ticket assigned to myself for now.

Mihai

December 7, 2023 at 3:08 pm #15018219

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Just so you know, I did not forget about you. 🙂

I'm running some final tests and I will get back to you as soon as possible.

Mihai

December 7, 2023 at 9:39 pm #15021199

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

I'm back.

Thank you so much for your amazing patience.

It seems that the issue here is that the pages were NOT updated after editing the Bethel settings according to the WPML documentation that I shared above.

As soon as I just made a small edit in the Homepage for example, you can see here that now, we don't see only the title as we did before, please take a look:
hidden link

Let me know if you see the content, too, from your side now.

Have a lovely rest of the day.

Mihai

kerimE confirmed that the issue was resolved on 2023-12-09 09:39:53.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.