Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Shekhar Bhandari 1 year, 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 21, 2019 at 4:54 pm #4434073


I am trying to:
Enable multicurrency
I enabled the currencylayer API and added 6 currencies when I saved the settings I could no longer reach the website.
I checked the server and the CPU usage is 100%

Please help

August 22, 2019 at 8:51 am #4437571

Shekhar Bhandari

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

We recently released a new beta version of the plugin with improved performances so could you please try this on a staging server and let me know if this helps?

Since this is a beta version, I request you not to try this on live site.

Further, performance issues depend upon the site, the server, plugins used and furthermore. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

We recently released new versions of WPML plugins with improvements and fixes. Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See:

Can you please review the following articles and see if all the relevant steps are covered?

Try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

What type of hosting do you have? Shared, VPS, Dedicated, etc?

Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Thank you for helping us pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.


The topic ‘[Closed] Mulitu currency causes server cpu usage 100%’ is closed to new replies.