This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by itaiA-2 3 months ago.

Assigned support staff: Bobby.

Author Posts
July 17, 2019 at 5:37 pm #4232661

itaiA-2

Hello,

After having applied a solution to a problem described here: https://wpml.org/forums/topic/currency-api/

My site has broken 🙁

Specifically, now all currencies in the table are selected (as I erase them they reappear) and an error code appears.

I've tried uninstalling and reinstalling the woocommerce module but the error is still there and the currencies all reappear in my table.(see photos). Obvoisly I don't want to loose all my translations so wpml reinstall is not an option....

Please help,

Cheers,

Itai

July 17, 2019 at 8:17 pm #4233329

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i am sorry to hear this has happened. It is always recommended before making any changes on the site or the code of the plugins to have a backup in place, do you currently have a backup you could use ?

Also if i understand correctly you added

private $api_url = '<em><u>hidden link</u></em>';

in the file /wp-content/plugins/woocommerce-multilingual/classes/multi-currency/exchange-rate-services/class-wcml-exchange-rates-fixerio.php at line 11

have you now removed the code you added ?

July 17, 2019 at 8:33 pm #4233411

itaiA-2

I have tried removing the code and putting it back, reseting the api. Always the same thing. That API does not read as valid, the table gets bloated with ALL the currencies and as I erase them they come back.

My latest backup is from 2 days ago, before all the translations...argggg...

Is there a way to save the translated content before doing a full restore?

July 17, 2019 at 8:57 pm #4233487

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

After you remove the code, are you able to remove the currencies manually without them coming back?

This fix is actually not needed anymore as this is an older issue(about 5 months ago) that our developers added a permanent fix within our plugin (WCML)

please do note the following

1. With free fixer.io you can have only EUR for primary currency (for the free account)

2. With currencylayer you can have only USD for primary currency (for the free account).

also regarding the translations you might be able to export any work you did the past 2 days for translations and then use WPML ALL import plugin

https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

July 17, 2019 at 9:20 pm #4233565

itaiA-2

I have replaced the actual file with the original from the downloaded plugin.

The currencies keep reappearing whenever I do a save.

I don't need currency exchange, I'm trying to set my prices in Euro and USD manually.

I really don't understand what's going on. Based on the errors, which files should be reset? will reseting the prefs to default help?

July 17, 2019 at 10:21 pm #4233655

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

i recommend to just delete Woocommerce Multilingual and replace it with a fresh version downloaded from here

https://wpml.org/downloads/

the fix that you added was for the automatic currency exchange API, i apologize but i am confused on what you have done at the moment that causes this behavior.

after removing the plugin and re installing it what are your results (your translations will not be lost)

July 17, 2019 at 10:34 pm #4233737

itaiA-2

Like I said in my original post, I did try that already.
I will do an uninstall-delete-reinstall of the woo-wpml plugin again. Who knows maybe I'll be lucky.

Thanks. I'll report back.

July 17, 2019 at 10:56 pm #4233863

itaiA-2

Sad to say: did the, uninstalling, deleting, reinstalling. Did not work!
à
Here is a photo of the error and the bloated table.

Any ideas?

Cheers,

i

July 17, 2019 at 11:15 pm #4233899

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If this was caused indeed by adding the custom code on your site then the best option would be to restore using your backup.

to verify that this is not an actually compatibility issue between WPML and a 3rd party plugin i would like to take a closer look

and to just make sure the goal would be to remove all these currencies and leave only EUR and USD ?

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 18, 2019 at 1:43 pm #4239295
itaiA-2

Also: while you're looking at my site. See the little red dot to the right of 'info' on my nav bar?

When I activate the french language I get 2 of those. They're clickable and they take up space. Even when I only configure a dropdown menu, I see them on top of the dropdown menu.

New threads created by Bobby and linked to this one are listed below:

https://wpml.org/forums/topic/split-multi-currency-bug/

July 18, 2019 at 8:09 pm #4242185

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

The notices were generated due to 3 currencies , and have been removed now along with all the additional currencies.

I have added Euro and USD along with CAD (default)

For the "dots" on your menu i have opened a new thread as we try to keep each issue separate and 1 issue per ticket

July 19, 2019 at 8:38 pm #4248105

itaiA-2

I have setup CAD, Euro and US currencies.
I have the following issues:
-the currency switcher on the product page only shows CAD & US currencies (Euro prices were entered in product page but do not appear)
-Variable products don't have currency widget? (prices were entered in product descriptions)
-Cannot add any other currency. I add it but doesn't appear in product table....

Best,

Itai

July 21, 2019 at 4:17 pm #4252721

itaiA-2

Finally, I've switched to WOOCS.

After having disabled the wpml currency switcher I no longer have access to the woocommerce multilingual tab?? Whenever I click it, I'm sent to my homepage.

Cheers,

i

July 22, 2019 at 3:05 am #4253569

itaiA-2

Figured out myself.

Cheers,

i