This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by martinV-32 6 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
April 5, 2019 at 1:46 pm

martinV-32

I have 4 domains: ledfashion.eu, ledfashion.cz, ledfashion.sk, led-fashion.hu. Each domain is for different language. I did the setup based on this "how to" https://wpml.org/2016/04/use-wpml-different-domains-per-language/.

But when I open hidden link it redirects the site to ledfashion.eu domain.

When I type hidden link it works fine (no redirect).

Same problem is on domais ledfashion.sk and led-fashion.hu.

The main language of WordPress is english on ledfashion.eu domain.

Could you please tell me what is wrong and how to fix it?

Thank you.

April 5, 2019 at 6:32 pm #3546363

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Have both domains been configured to work with https? Note that your server must be configured so that all domains can work with https.

Also, also, when I try to access your FTP, it looks like the credentials are incorrect:

Status:	Resolving address of ledfashion.eu
Status:	Connecting to *******:21...
Status:	Connection established, waiting for welcome message...
Status:	Initializing TLS...
Status:	Verifying certificate...
Status:	TLS connection established.
Command:	USER *******
Response:	331 Password required for *******
Command:	PASS **********
Response:	530 Login incorrect.
Error:	Critical error: Could not connect to server

Please, could you check?

Thank you.

April 8, 2019 at 10:38 am
April 8, 2019 at 6:49 pm #3560871

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. This seems like the problem is fixed. When I access your website by switching languages, the domain works correctly.

About "xdomain_data", this happens so that one domain can pass cookies to other domains (this is useful for WooCommerce, for example). That is, this is not a bug, this is the default behavior of WPML.

If you want, you can disable this in WPML > Languages > Language URL format, check the "Disable this feature" option under the "A different domain per language".

You can see more details in our documentation: https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

April 8, 2019 at 7:14 pm #3561011

martinV-32

Hello,

The problem is not fixed. Switching languages worked all the time. The problem is that when you directly access hidden link it redirects you to hidden link (which it should not do). The same redirect is also on hidden link and hidden link

That is the problem that we are dealing with and that we do not know how to fix. It ruined our SEO because now Google thinks that only ledfashion.eu domain exist and all those other domais do not rank at all.

Could you please take a look at it?

Thank you.

April 10, 2019 at 8:07 pm #3581131

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Now I've been able to replicate the problem you are reporting.

As a test, have you tried to disable all WPML plugins to see if the redirect will persist?

I'm asking this because it does not seem to be a problem in the WPML configuration. This seems to be related to some redirect that was created somewhere else on your site.

Ideally, you should disable all plugins and switch to the default theme and check if the redirection is still done. If so, then this is some configuration of your server.

If the problem is fixed, you should enable the plugins one by one to know which one is doing the redirection.

Please note that I can not now access your site anymore. A new credential request (HTTPAuth) appears before the WordPress login screen appears.

Also, since your site is in production, in addition to backup, ideally you should follow the steps above.

Thank you.

April 12, 2019 at 6:55 am #3595319

martinV-32

The errror was caused by wrong .htaccess file on our server, not by the WPML plugin