This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Jamal 2 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
August 7, 2019 at 11:31 am #4354353

Alessandro

I am trying to: login in Italian language. after login I change language and i'm not logged in.

Link to a page where the issue can be seen: tenerifesuprise.it

I expected to see: logged in all languages

Instead, I got: I have to login everytime in a single domain

I'd like to be supported by Yvette

August 7, 2019 at 4:03 pm #4356669

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

You will need to activate the "Auto sign-in and sign-out users from all domains" in WPML->Languages. Read more about it in this documentation article.
https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/

Best regards,
Jamal
WPML Support

August 7, 2019 at 4:06 pm #4356685

Alessandro

Good morning Jarnal,
Obviously (for me 😀.... sorry I didn’t write it) I already did what You say, but doesn’t work....
Regards
Ale

August 7, 2019 at 4:33 pm #4356875

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Can you test both settings (Pass arguments via GET and POST)?

If it does not help, please check if this issue appears when:
- Only WPML plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Can you also check with your hosting provider if there is any caching system implemented in the server level and ask if it can be disabled for testing?

Best regards,
Jamal

August 7, 2019 at 4:41 pm #4356925

Alessandro

Hi,
I will try all step indicated.
For information at the moment the only one caching system is cloudflare.
By the way I will let You know asap.
Regards
Ale

August 8, 2019 at 8:03 am #4360605

Alessandro

Good morning Jamal,
I'll try to resume what I did.
1. deactivated all plugin (KO)
2. deactivated theme core (KO)
3. change get to post and viceversa (STRANGE BEHAVIOUR):
I have 3 languages italian (base domain), english and spanish (managed via wpml with multidomain option different domain per language).
To undertand if I was logged in l checked in the homepage if the admin bar exist.
If I use GET option:
Italian (Login ok Admin bar ok)
English (Login ok Admin bar ok)
Spanish (LOGIN KO - NO admin bar)
If I use POST option:
Italian (Login ok Admin bar ok)
English (LOGIN KO - NO admin bar)
Spanish (Login ok Admin bar ok)
So I took a look in the documentation https://wpml.org/documentation/getting-started-guide/language-setup/passing-session-data-between-languages-in-domains/
So waht I did?
I added in the url (that was not logged in) the following string

?xdomain_data=LONG_STRING

....and it worked !!

In the documentation thay say that there's a language switcher I have to pass this argument. Now the question is: How can I archieve that?
Thank You very much for Your support!!
Ale

August 8, 2019 at 9:58 am #4361625

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback.
Can you activate the Ajax cookie in WPML->Lanauges->Language filtering for AJAX operations then test again both with POST and GET?

Can you also deactivate the "Assume that the original language of all strings is English" in WPML->Theme and plugins localization->Localization options

I also wonder if you are using a custom language switcher on your website? If yes, please add another default language switcher in the footer and test with it.

Best regards,
Jamal

August 8, 2019 at 12:52 pm #4363073

Alessandro

Hi Jamal,
I changed Language filtering for AJAX operations then test again both with POST and GET and no working.
Inserted the widget in footer but nothing changed.
So now the cfg is:
GET ON
Language filtering for AJAX operations OFF
Assume that the original language of all strings is English OFF (was OFF also before)
I noticed that the behaviour is different between firefox, safari and chrome (on mobile iphone don't work).
I suppose there is a bug in the cache management.
In any case I use the following code in the header:

<?php do_action('icl_language_selector'); ?>

I really don't know how figure it out...
Please help me...
Thx
Ale

August 8, 2019 at 3:35 pm #4364291

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Ale,

I still suspect a cache issue. That's why I would like to migrate your site to our infrastructure. If the issue does not appear it means that's a cache or a server issue. If the issue still appears in our servers, maybe it is something with the theme.

Please follow the instructions in my private message(AUGUST 8, 2019 AT 3:34 PM) to migrate your site. I will then create the other domains and link them to the installation.

Best regards,
Jamal

August 8, 2019 at 8:23 pm #4365773

Alessandro

Good evening Jamal,
we don't use any cache system (only cloudflare but I purged all).
Unfortunatly I tried to migrate but I received the error attached.
The file system of wp-content is about 14,4 Gb.
How can we proceed?
Let me know
Thx very much
Regards
Ale

August 9, 2019 at 9:01 am #4368843

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Please allow me temporary access to your backend. I will install the Duplicator package and try to create a copy of your website, using filters to reduce the size of the copy. Then I'll rebuild it first locally to test, and probably rebuild it in our server too.
The private area is activated to share credentials securely. Make sure to have a database backup.

Best regards,
Jamal

August 9, 2019 at 11:39 am #4369815

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I was not able to migrate the website or to create a Duplicator copy. I suspect that a security plugin(maybe WordFence) or Cloudflare is blocking me from both actions.

Duplicator completes scan but does not complete build, it took me to a Cloudflare error page. Then the package is at 59%. I tried it twice. See attached images.
Please check if you can deactivate WordFence and Cloudflare just for the time to create a Duplicator package. Use the configuration in the attached image.
To remove a failed Duplicator package, go to Duplicator->Settings and click on "Reset packages".

If you can't create a Duplicator copy, we may need to do it the old way. A database dump and a zip file of your website.

I activated the private box to share download links securely.

Best regards,
Jamal

August 9, 2019 at 12:09 pm #4370115

Alessandro

Hi Jamal,
Since we have 14gb can I avoid to give You the entire WP-content?
Please let me know.
Thx
Ale

August 9, 2019 at 1:23 pm #4370733

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Ale,

Sure. You can share a database export/dump and a zip file of plugins and themes folders. That should be enough. I'll create a new WordPress installation, import your database, and use your themes and plugins.
I activated the private fields to share download links.

Best regards,
Jamal

August 12, 2019 at 10:12 am #4379943

Alessandro

Hi Jamal,
have You got some news?
Thx
Ale