Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by patrizio-romanoD 4 years, 5 months ago.

Assigned support staff: Dat Hoang.

Author Posts
January 10, 2017 at 9:22 am #1178249


I am trying to:

At the moment, front-end we see no language switcher anymore, back-end in wpml > languages also doesn't show any available - see screenshot;
please consider that we didn't made any significant change from the last time we had a full check and the website looked working fine, 23rd of december: no plugin or wp version updates, nor code changes;
the only things changed are in database content, as the website had been getting new users registration and requests via forms;

So far, we tried the following steps:

Error log checking
At the moment we have a lot of error logs like this one:
... Illegal mix of collations (utf8mb4_unicode_520_ci,IMPLICIT) and (utf8mb4_unicode_ci,IMPLICIT) for operation '=' ...
We can provide a full error log.

Update wpml plugins and wordpress to the latest version:
This resulted in nothing but a lot of error 500, both on many pages front-end side and on many administration pages as, for example, the plugin list page;
Deactivation of string translation plugin via ftp solved only the 500 errors;
At the moment the website is working after a downgrade, with wp 4.6.1 and previous versions of all the WPML plugins.

WPML support solutions in threads:
we tried to follow the steps suggested on the following link and on other similar threads marked as solved:
This resulted only in changing the tables mentioned into the error log.
At the moment we restored a previous database version with no changes on tables collations.

URL of (my) website where problem appears:

The website affected is hidden link
We made a full copy on for testing and debugging purpose;
Please consider also that even if languages looks broken, translations urls are online and look working, as you can see on

Thanks in advance for your help,

January 11, 2017 at 7:38 am #1179156

Dat Hoang

Can you please run this SQL to all of your tables?

ALTER TABLE	 wp_table
CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

Does that help?


If not, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this:

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

January 12, 2017 at 3:25 am #1180127

Dat Hoang

Thanks for your credentials.

I confirm the new issue with the error 500. I've just had a quick check but I have not found any issue. Since the original issue is really solved, I am going to mark this "Resolved".

Can you please help me to open a new ticket, then refer this ticket and assign it to me? I will spend more time to check.
In each ticket, we focus on only one problem. That helps others with the same problem find the solution quickly.

By the way, the error 500 is a server error. Please check your server (nginx) error log as well, and let me know about that in your new ticket.

January 12, 2017 at 8:16 am #1180267


Thanks Dat Hoang,

I thought I could do that way, I was waiting for your suggestion.
I'm going to make a new support request right away, in order to help you proceed with the other issue.
Thank you very much,