This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 26, 2018 at 12:17 pm

angelR-7

Hello,

I'm having a problem. I'm using WPML to translate my website in 2 different languages. When I'm translating a property listing, the picture gallery does not transfer to the other languages, even though I have checked the box that says "duplicate uploaded media to translations". For example:

Original: hidden link

Chinese: hidden link

Russian:

hidden link

The problem is the same for every other property listing. Please let me know how to fix this issue.

I have already contacted the support for houzez theme which have advised me that this is unsupported by them and you are the ones who should help me resolve this. Thank you!

September 27, 2018 at 6:36 pm #2771588

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @angelr-7, welcome to the WPML support Forum!

Are these images added through custom fields? If so, please try the following:
- Go to the edit screen of the page (default language)
- scroll down to Multilingual Content Setup
- Check if there is some custom fields related to the images/gallery. If so, set them to "Copy"
- Click on Apply
- Scroll Up, do a small modification on the page content and save
- Edit the translation and save

Please let me know if it worked for you.

All the best,
Diego

October 2, 2018 at 1:19 am #2779733

angelR-7

Hello,

I apologize for the late response.

Everything connected to pictures in the multilingual content setup has already been set to "copy". Please use the login credentials I provided to look at the settings. The issue still persists.

Please let me know how to proceed. Thank you!

October 2, 2018 at 2:59 pm #2781969

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. This seems to be a new compatibility issue of the theme. In these cases we should test the theme on a clean installation, to isolate the issue and run some tests.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the theme to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the theme and the related functionality, you don't need to setup a entire website or clone your existing site.

You can also use this workaround to fix the issue on the product:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"
- Add the images to the translation and save

Regards,
Diego

October 3, 2018 at 9:29 am #2784058

angelR-7

Hello,

I'm afraid that I have an issue with reproducing the environment over at your sandbox. When I bought the Houzez theme I got sent 1 license activation key. Currently the feature through which you upload photos, is unavailable on the sandbox due to the theme not being activated. In order to activate it I need to use the same key and I'm afraid that it might invalidate my current license key on my original website.

How should I proceed in this case?

October 3, 2018 at 7:55 pm #2785618

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I am checking with my team if there is an alternative to investigate this issue. I'll send you feedback soon.

Regards,
Diego

October 4, 2018 at 12:24 pm #2787460

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We are contacting the theme authors to get a temporary license. I will send feedback soon.

Regards,
Diego

October 5, 2018 at 5:13 pm #2791396

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

We have not received any feedback from the author yet. Could you contact the theme support, mention our contact and ask if they can offer a temporary test license for debug?

Regards,
Diego

October 7, 2018 at 2:40 am #2793401

angelR-7

Hi,

I apologize, but my support for the theme just expired, and I kind of don't plan on spending $40 so I can write to them. I hope you can understand. I also found another bug that is connected to translating a property listing grid, which I will explain in 1-2 days since I don't have the time to properly inspect it yet.

October 8, 2018 at 4:16 pm #2796918

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In this case we need to wait for the subject's author's response to our team. We sent a followup email but until now we have not had an answer. Since this is a compatibility issue, we need the collaboration of the author.

Have you tried the manual translator workaround? If not, please test:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"
- Add the images to the translation and save

For new translations, you can also try this workflow
- Go to the edit screen of the page (default language)
- Duplicate the page to the secondary language through the right sidebar
- It will copy all fields to the translation. Click on "Translate Independently" to edit it

Please let me know if it worked for you.

Kind regards,
Diego