Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Otto 5 years, 10 months ago.

Assigned support staff: Otto.

Author Posts
February 4, 2016 at 7:10 pm #805263

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

I'm really glad we are moving forward.

I think that it will be much better if we can work together in the same site. I asked a test server to upload your site. When ready I'll send credentials to you so you can access there too.

It will be really helpful if you can make a copy of your site using the Duplicator plugin. This will help me a lot in the process of cloning your site to the server.

You can provide me with the snapshot following these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

Please refer screenshot attached, remember to enable the filters and exclude the things as shown in screenshot:

+ wp-uploads
+ cache
+ media
+ archive

Excluding these things will help in keeping the snapshot size minimum

:: Duplicator instructions
hidden link

. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

Once the problem is resolved I will delete the local site.

I am enabling private message for your next reply so that you can send me snapshot link and admin details of account you will create for me.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

February 4, 2016 at 8:40 pm #805334

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Thanks Adri!

Yes, you can continue working on the site. When the test server is ready I will deploy the site there and we can apply the changes or update it if there are many.

I think this will help us to improve the workflow. I already asked for it. Anyway I`ll check the snapshot locally.

I'll get back to you tomorrow.

Kind Regards,

Otto

February 4, 2016 at 8:51 pm #805338

adriO

Ok, have a nice evening.

February 5, 2016 at 11:14 am #805770

adriO

Hi Otto, goodmorning,

I have an update to the issue we are handling. This morning I discovered that the missing menu options in the dashboard were visible. I was very surprised. I checked if the bbPress multilingual plugin was activated but it was not. WPML Multilingual CMS is activated. So it appears to be ok (for now). What's puzzling me is the reason why it went wrong (and second to that why it is ok now). Maybe you can find something in the site I send you. I found out that there are a lot of similar issues on a variety of forums on the net but no solid solution.

Like I told you in my former post I was questioning myself why the visitor must be able to choose a different language on a bbPress page. I concluded it is not needed because the topics and so in the forum must be in English only.
Therefor I created some logic to hide the language switcher in the header when the visitor is on a bbPress page with this function:

<?php if (!is_bbpress()) {
do_action('icl_language_selector'); 
}?>

Works great! There is one thing left and that is the language switcher in the footer. As you can see it is set in the WPML settings and called by the wp_footer() function. See screenshot. I don't know how to hide it only on the bbPress pages. Do you have a suggestion?

I'm happy with the way this issue is progressing to a solution. I think we have made some giant steps already.

Thanks in advance.

Adri

Schermafbeelding 2016-02-05 om 11.35.14.png
February 5, 2016 at 11:30 am #805789

adriO

Hi Otto,
The story of my life.... I ask a question and right after that I find it.
Hiding the language switcher in the footer is achieved in the same way as the switcher at the top. I only had to address the right type of selector (in this case: wpml_footer_language_selector) and unselect the option in the WPML settings.

So, for this moment all is working fine, I only am very curious I f you can find anything about the disappearance and suddenly appearance of the admin menu options.

Adri

February 5, 2016 at 11:54 am #805816

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Wow!!!

All is working fine?!!?!? Amazing, you did a great job. I'm really glad.

I'm cloning your site locally and checking that issue. Which is strange indeed. In my test site I never miss it.

Anyway, I'll be back to you soon.

Kind Regards,

Otto

February 5, 2016 at 12:03 pm #805827

adriO

Amazing isn't it?
You pointed me somehow in the right direction.... a true inspirational source so to say 🙂

I'm very happy right now. After a year of struggling ( see the other thread) it looks like we finally solved it.

I hope you can figure out why the menu options behave so strange. Maybe it is my local setup.
MAMP (on the mac).

Adri

February 5, 2016 at 12:20 pm #805843

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

I cloned your site locally and the issue with the menu items is present. I'm on MAMP too.

I tried this to bring them back and as far as I can see it works:
-I modified this file in bbPress Multilingual to set the translation options:
wp-content/plugins/bbpres-multilingual/wpml-config.xml

As you can see here you can use this file to set them to translate or do nothing:
https://wpml.org/documentation/support/language-configuration-files/

-Then I activated it

I don't know how you managed to get them back... but this way seems to work.

Can you please try it and let me know if you find any issues?

Kind Regards,

Otto

February 5, 2016 at 2:10 pm #805954

adriO

Hi Otto,

I followed the steps you provided in your last reply. I can't see any differences so it appears to be ok. Changing the xml file (setting all to 0) tells the plugin to do nothing. The options for translate or not are not displayed anymore in the WPML Translation Management options for custom posts. I think basically we told the plug in to be inactive. Never the less, it works.

I don't know how I got them back in the first place. As I told you I was surprised this morning.

As far as I'm concerned, this issue is resolved. What's still stands is that, like Amit and others told me, bbPress and WPML are not fully compatible. There is some work left. And although Amit has decided that it has no priority I think the opposite. Widely used plugins like bbPress and WPML must be compatible. That's why I left the other thread open.

I want to thank you very much for your patience and help.

Have a nice weekend!

Kind Regards,

Adri

February 5, 2016 at 2:28 pm #805973

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Adri,

Exactly, the steps provided helps to activate bbPress Multilingual and keep the bbPress configuration that worked for you. So if you didn't notice any changes that's great.

I'm really happy you finally solved this issue.

If you find other issues please open a new thread, I'll do my best to help.

You too have a nice weekend 🙂

Kind Regards,

Otto