This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by svenU-4 1 year, 4 months ago.

Assigned support staff: Bigul.

Author Posts
June 7, 2018 at 9:09 am #2392070

kenL-6

I am trying to:
log in WooCommerce via Traditional Chinese (second language) page

Link to a page where the issue can be seen:
hidden link
(In main menu bar, the menu item is "我的帳戶")

I expected to see:
Normal login page

Instead, I got:
404 Page not found.

June 8, 2018 at 4:42 am #2398778

kenL-6

I have modified the Chinese main menu my account link to English My Accont page (change o custom link)
Remind that the original link in problem is
hidden link

If you need yo see my server setting, you may visit:
hidden link

thanks

June 8, 2018 at 2:07 pm #2400316

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you translated the My Account page to Chinese? Please try the following steps after a backup and make sure the issue is existing or not.

1) Visit WPML>>Languages, choose *Language name added as a parameter* option for *Language URL format* and save the changes
2) Visit Settings>>Permalinks, just resave the changes
3) Then check the *My Account* page is loading for you correctly
4) Visit WPML>>Languages, choose *Different languages in directories* option for *Language URL format* and save the changes
5) Visit Settings>>Permalinks, just resave the changes
6) Then check the *My Account* page is loading for you correctly

--
Thanks!

Bigul

June 8, 2018 at 10:03 pm #2401263

kenL-6

I have followed your step but no help

June 11, 2018 at 1:17 pm #2405129

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 12, 2018 at 4:13 pm #2408887

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. The My Account page is working fine in English and Chinese for me now. I have updated the slug translation of the My Account page. Please check the attached images and let me know your feedback.

--
Thanks!

Bigul

June 12, 2018 at 4:55 pm #2409125

kenL-6

Thank you very much 🙂

August 27, 2019 at 7:17 pm #4469227

svenU-4

Hello, we have the same Problem with our site can u Check this pls!

Everything works in German. I can log in and have various pages available for the user after logging in. (see Image)
However, if I choose English or French and then click on one of the pages in the user menu, it comes to a 404(see Image)

hidden link

Thx