This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

All /my-account links points to /my-account url endpoint.

Solution:

-go to WPML -> Pages -> Post type translation -set the 'Pages' to 'Translatable - only show translated items' -Save.

This topic contains 4 replies, has 2 voices.

Last updated by kenL-6 6 months ago.

Assigned support staff: Dennis.

Author Posts
February 22, 2019 at 12:37 am

kenL-6

I am trying to: My account show orders, etc

Link to a page where the issue can be seen: hidden link

I expected to see: working normally

Instead, I got: my-account/order, my-account/edit-address, my-account/edit-account, my-account/customer-logout link all show my-account only

temporary user id and passeord: WPMLtest2019 / test2019WPML (as administraor)

February 22, 2019 at 5:21 am #3230976

kenL-6

I found this issued happened two years ago
https://wpml.org/forums/topic/my-account-pages-not-working/

I have reinstalled the related plugins but no help, only deactivated the WMPL plugins can make the My Account page work as normal but is it no the solution.

Please advice, thanks

February 22, 2019 at 6:31 am #3231024

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

We have some clients with similar cases with regards to woocommerce my account page links leading to /my-account endpoint.

After a full website backup, could you please take these steps?

-go to WPML -> Pages -> Post type translation
-set the 'Pages' to 'Translatable - only show translated items'
-Save.

Does it help?

Kind regards,
Dennis

February 22, 2019 at 7:10 am #3231126

kenL-6

Thank you for your reply.

It works!

However, is it a temporary solution or will there be a new fixed version to be update?

February 22, 2019 at 7:13 am #3231128

kenL-6

My issue is resolved now. Thank you!