This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 3 voices.

Last updated by khalidA-27 5 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
May 1, 2019 at 4:43 pm #3718937

khalidA-27

Hello
I have some small issues I need help with.

1- My account page was translated successfully with its permalink. But its includings are not. Addresses, orders, downloads and account details are translated correctly but their urls lead me only to my account page. urls are not translated. Why these four only from all site's urls are not translated and how to translate them correctly to refer to correct pages?

2- My panel language is English. How to keep it like that and make my sites default Arabic?

3- How to add /en to my English version? it Only appears in Arabic as /ar .

3- How to add subdomain to both english and Arabic languages

4- What is the benefit of translating media? I will use different media for every version. What to be done?
Also there is an option of duplicating media in translating, does this affect site SEO?

I hope I hear from you soon

May 1, 2019 at 8:13 pm #3719771

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us.

About your first question about the URLs of your site, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Are you using any plugin or cache system? If so, have you tried clearing your site's cache to see if the problem persists?

Also, have you tried to disable all non-WPML plugins (keeping WooCommerce and WooCommerce Multilingual enabled) to see if the URLs are still going to be displayed incorrectly?

Regarding the other issues you are reporting, may I kindly ask you please to open a new ticket for your new question? According to our guidelines, only one issue per topic is allowed. Also, this will also help other users with similar problems find solutions when searching the forum.

Thank you.

May 1, 2019 at 8:31 pm #3719843

khalidA-27

Thanks for your reply

Here is debug info.
I'll check the rest of the points and open new ticket for each if they still.

May 2, 2019 at 10:03 am #3723579

khalidA-27

Hello

In the link more explanation to the issue hidden link

I hope tp hear from you soon
Thanks

May 2, 2019 at 4:35 pm #3726993

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for the screencast. Have you tried the steps I posted above to see if any compatibility issues are happening - and why the link in the secondary language cannot be accessed correctly?

Also, I noticed that you are using a cache plugin. Have you tried cleaning it to see how the links will behave?

Thank you.

May 2, 2019 at 5:48 pm #3727929

khalidA-27

I cleared cache for both browser and plugin.
disabled different of other plugins
But the issue remains.

Please help

May 3, 2019 at 4:46 am #3730829

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 3, 2019 at 4:38 pm #3736933

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Since Bruno currently has a few days off, I will replace him here in the forum. I hope this is OK for you.

This sounds like this know issue: https://wpml.org/errata/when-pages-are-set-to-display-as-translated-all-endpoints-in-my-account-page-for-secondary-languages-lead-to-defaut-language/

This issue was fixed on WCML 4.6.0, but i'm not sure why it's not fixed on your website.

It's possible to set the Pages post type as "Translatable - only show selected items"? I did a quick test on your website and it worked.

Please let me know if it worked for you.

Kind regards,
Diego

May 4, 2019 at 6:52 am #3739325

khalidA-27

My issue is resolved now. Thank you!