Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by kellyh 4 years, 9 months ago.

Assigned support staff: Andrés.

Author Posts
May 2, 2015 at 11:01 am #610538

kellyh

I am trying to: translate custom shipping methods and wishlist features on checkout page. I have translated the strings but no result. When refreshing the page one of the shipping methods appears right and than it jumps back to default language. Also the wishlist features dont come out translated in the second language... I am having a very hard time translating my wishlists too, I made a ticket at woothemes ofr that too, do you have advice in that matther too? the website worked great before tranlating.. Now I feel really lost because I dont seem to get the website in 2 languages as it worked on the default language...

Can you help please?

Kelly
( I made a previous ticket for another problem, when trying to answer it, I could not. I got the message I was not logged in, but I was...)

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

May 2, 2015 at 11:04 am #610540

kellyh

And a screenshot of the problem with shipping method and wishlist features. On the right you see sidebar with all the details. When viewing in french ( second language ) they dont show translation...

"Van geboortelijst:" is translated in string translation
"Naar de ouders verzenden" also translated
"Naar mezelf verzenden zodat ik het zelf kan overhandigen" also translated

May 2, 2015 at 11:06 am #610542

kellyh

From the previous picture;

The colours of the item are also not translated. They are in de products of Woocommerce multilingual dough

May 4, 2015 at 9:03 am #610988

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Kelly,

Thanks for contacting WPML forum support.
The issue you described with your previous ticket is a known cache issue. For this, you should:
- Log out
- Empty your cache (go to browser settings)
- Log in
Could you please close one of your tickets and continue in any of both channels? If you prefer to stay here, we can start doing this:

1. From the description of your problem, maybe you've already done this, but could you repeat this action:
- Go to WPML -> String translation
- Select strings within context -> admin_texts_plugin_woocommerce-multilingual
- Select the string
- You can also search directly the string you are looking for typing on the Search for field.

2. You can also check if your text is been wrapped into a GetText function, this allows strings being able to be translate:
- Search into your theme
- Replace every 'String' for <?php _e('String','Your-Theme-Name'); ?> syntax

More information here,
https://wpml.org/faq/language-setup/

Regards,
Andrés

May 4, 2015 at 9:31 am #611017

kellyh

Thanks,

You are right about the cache problem, many where solved by deleting cache, thanks! I will take the steps you suggest for the few strings I still have problems with.

If I may I have another question.. I made several tickets with the author of the plugin but they keep replying with answers that dont rely on my problem, because of my english I think...

It's about private content plugin. I have a problem with their private page. I know the private page itself is not translatable. But you have to set a container for the private page per user. That is where the issue with WPML comes... I can only set 1 page as the container in settings. The result is my dutch users can see their private page, but my fench users not. Their private page also appears on the dutch site... Is there a chance you have a solution for me? So the private page is unique to each user and you have to set a container for it. Only 1 page can be selected. So as a result the private is visible in only 1 language. Any suggestions?

Thanks in advance!
Kelly

May 4, 2015 at 9:55 am #611044

kellyh

Hi,

Sorry in the previous post I mean User page, not private page... Sorry.

May 4, 2015 at 11:23 am #611149

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thank you for your feedback.

In order of being a better help, I kindly ask you to open another thread for your compatibility issue with your plugin. It will let me dive you a better support and other users to find the solution we find to your problem. I only can tell you that we may need to contact your plugin's author.

I'll wait for your findings about your strings translation.

Regards,
Andrés

May 5, 2015 at 6:26 pm #612560

kellyh

Ok! Everything is translated now and working fine! Evendough I cleared the cache several times, the translations came true after a while without doing anything extra... So still the cache causing some delay I think?

Thank for the help! Still having troubles with the wishlist dough... Therefor I made new ticket.

Kelly