Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by hollyJ 7 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
October 3, 2021 at 2:22 pm #9711597

hollyJ

Tweek translations which were initially done with advanced translation and DeepL. It appears these are not saving to the front end. I've attached a screengrab of what it should show and what the preview shows.

Screenshot 2021-10-03 at 15.17.05.png
Screenshot 2021-10-03 at 15.16.39.png
Screenshot 2021-10-03 at 15.13.38.png
October 4, 2021 at 9:00 am #9714485

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!

Could you try the following please:

- Update the original language of the page shown in the screenshot (Add a character to the title and save it)
- Try to update the translation now
- Make the tweaks to the translations again and save them
- Set the translation as complete
- Wait a few minutes and check if they work now.

Let me know how it goes and if this works.

October 4, 2021 at 12:34 pm #9716145

hollyJ

I'm afraid that didn't work. It shows the changes in the english side, but not the french. Here are some screengrabs.

To be clear, I take it I should always only use the translation on the page and not the top wp menu which gives me a message 'you are trying to edit using the standard WP editor, but your site is configured to use the WPML Translation Editor. (I went back when this showed and only did the translation using WPML translation editor.)

Screenshot 2021-10-04 at 13.25.20.png
Screenshot 2021-10-04 at 13.24.20.png
Screenshot 2021-10-04 at 13.22.39.png
October 4, 2021 at 2:16 pm #9716873

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

October 5, 2021 at 8:01 am #9721257

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Please check this video out: hidden link

There are 2 things that i did in order to have everythnig working correctly:

1) Disable the cache on your site: this is very important because when caching is enabled you're going to be proned to see old versions of your site and not see the changes go through immediately.

2) Update your original page before editing the translation (this helps make sure the translation goes through correctly, it's not strictly necessary but sometimes if there were changes deteted by WordPress, editing the "old" translation might not send the content correctly to the translated pages).

Try that and let me know how it goes.

October 5, 2021 at 9:46 am #9722205

hollyJ

Thank you so much Alejandro for such a great and comprehensive video and explanation. I actually do normally have the caching off and do a manual flush at the end of any update (using the top wp menu). I switched it on for your use. I was not aware that memcached also creates problems.

I would also like to know how to see the media in a page when I do a translation and I think I set that up incorrectly to start with. I have seen on other tutorials where the images for the page automatically show up (I am aware that I need to handle sliders, headers, global and footers separately). Is it that I need to turn on the 'Duplicate uploaded media to translations'
'Duplicate featured image to translations' radio boxes underneath the translation box (screengrab attached).

Also should I be turning on any of the custom fields which I know are used (screengrab attached) and if so which option should I choose?

Many thanks again for your help. Hopefully once I am up and running I won't need to hassle support!!!

Screenshot 2021-10-05 at 10.42.49.png
Screenshot 2021-10-05 at 10.35.21.png
Screenshot 2021-10-05 at 10.33.36.png
October 5, 2021 at 3:54 pm #9725445

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Is it that I need to turn on the 'Duplicate uploaded media to translations'
'Duplicate featured image to translations' radio boxes underneath the translation box.

These 2 need to be setup to send the media to the translated pages, yes.

If you want to translate the images (i.e: have different versions of the same image accross the languages) then you'll want to use the "media translation" plugin.

Also should I be turning on any of the custom fields which I know are used (screengrab attached) and if so which option should I choose?

I'm not sure where these fields come from, but when you see that it mentions IDs you can set them to "copy" since they should be translated automatically.

Only set to translate content that you actually want to se translatable in the translation editor. the rest i would not touch unless i notice something is missing. if the fields handle images, for example, then set them to "copy" and at most translate them using "media translation".

Regards.

October 6, 2021 at 9:52 am #9731027

hollyJ

Thanks, sorry I don't quite understand. I want to be able to choose to edit the text on the images of a page I am translating (I won't want to change all media, only some of the images on the pages I am translating).

Is there a way to set it up to show images in the translation (like it does with the body text). Or do I need to manually tick the duplicate image on each page individually when I go to do the translation. I thought I saw on a youtube tutorial (not one of yours) that the media on the page should show up in the autotranslation so I can edit if I wish.

Many thanks

October 6, 2021 at 10:18 am #9731369

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

1) You need to tick the duplicate checkboxes (the ones shown on your screenshots)

2) Update the page (maybe add a character to the title) and save the changes

3) Translate it. you should see the meta information in the translation editor.

IF you don't see it then please install "WPML Media translation" and then:

4) Go to WPML > Media Translations

5) Search the image and translate it from there (using the pencil icons or the + icons you'll see there)

6) Save the changes

7) You should see a notification showing where that image is located. if you read the notification it will ask you if you want to update the images in the other pages where they were inserted and update the content to the one you translated (description, alt text, etc).

8) Select the "slow method" and then wait until it finishes

You should have the meta information of the images translated and updated in the translated languages, now.

October 6, 2021 at 10:28 am #9731423

hollyJ

My issue is resolved now. Thank you!