This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I updated the cover/hero photo of my website. It appears changed in the english version but the old photo is seen in the french version

Solution: To solve the issue I went to Appearance -> Widgets -> Switch the admin language to French -> Edited the image and changed to the one in English -> Saved the changes.

Relevant Documentation:

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 29, 2019 at 3:10 pm #4660983

dianaG-8

I am trying to: I updated the cover/hero photo of my website. It appears changed in the english version but the old photo is seen in the french version

Link to a page where the issue can be seen:
hidden link

I expected to see: correct photo (English): hidden link

Instead, I got: old photo (French): hidden link

September 30, 2019 at 10:52 am #4663865

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 30, 2019 at 2:28 pm #4665305

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I went to Appearance -> Widgets -> Switch the admin language to French -> Edited the image and changed to the one in English -> Saved the changes.

Could you confirm that the issue is solved?

Regards,
Carlos

September 30, 2019 at 4:58 pm #4666673

dianaG-8

My issue is resolved now. Thank you!

September 30, 2019 at 10:59 pm #4667729

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos