This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 6 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 28, 2019 at 5:28 am #3477083

enzoS-5

I am trying to: when i run my website in enlish language its working properly but when i change my language to italian its search filter stop working my location list is removed from the destination in searc filter.

Link to a page where the issue can be seen:hidden link

I expected to see: i want all my location in search filter which have activity in it .

Instead, I got:there is no list of the location in available in search filter

March 28, 2019 at 9:25 am #3478651

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you translated the Destination options to Italian? Please share the screenshots of Search Filters admin settings for a better understanding of the issue.

Please visit WPML>>Languages and make sure the following options are enabled.

1) *Adjust IDs for multilingual functionality* option of *Make themes work multilingual* section

2) *Store a language cookie to support language filtering for AJAX* option of *Language filtering for AJAX operations* section

--
Thanks!

Bigul

March 28, 2019 at 10:11 am #3479131

enzoS-5

Hello Bigul,
i have enabled the setting that you have mention but still i am getting same error.
"Please visit WPML>>Languages and make sure the following options are enabled.

1) *Adjust IDs for multilingual functionality* option of *Make themes work multilingual* section

2) *Store a language cookie to support language filtering for AJAX* option of *Language filtering for AJAX operations* section"

March 28, 2019 at 10:14 am #3479167

enzoS-5

"Have you translated the Destination options to Italian? Please share the screenshots of Search Filters admin settings for a better understanding of the issue " .

please share me the steps so i will share you the screen shot

March 28, 2019 at 10:18 am #3479271

enzoS-5

"Have you translated the Destination options to Italian?" yes

March 28, 2019 at 3:11 pm #3482917

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

March 29, 2019 at 8:44 am #3489159

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. This may be happening because the translation preference is not set for the *Location* Post Type yet.

Please try the following steps after a backup and check you are getting the expected result or not.

1) Visit WPML>>Settings
2) Scroll down to *Post Types Translation* section
3) Choose *Translatable - use translation if available or fallback to default language* option for the *Locations* Post Type
4) Save the changes

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

March 29, 2019 at 9:17 am #3489311

enzoS-5

Update the detail that you have mention but still not getting list in search filter

March 29, 2019 at 9:23 am #3489367

enzoS-5

i want to display all activity in both language if language available than transalated if not display in the same English version we don't want to update the every activity for transalated location .

March 29, 2019 at 7:21 pm #3494239

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Now the Location posts are showing in the *Destination* option in Italian. But the search result is not showing any activity. This may be happening because the translation preference is not set for the Activity Custom fields. Please check the attached images for more details.

Please choose relevant translation preference for the custom fields like *Copy* or Translate(after a full site bckup). Then create an Activity Post and translate it to Italian. After that check, you are getting the expected result or not.

Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

--
Thanks!

Bigul

April 4, 2019 at 8:59 am #3533331

enzoS-5

i update this settings but still not able to see the search result

April 4, 2019 at 9:04 am #3533363

enzoS-5

New activity is displaying in search results but old activities are not displaying in the search results

April 4, 2019 at 3:24 pm #3536539

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please create a new Activity post in English and translate it to Italian, and make sure the issue is existing or not.

Also please update the translated Activity posts in both languages and check it is showing in the search result or not.

--
Thanks!

Bigul

The topic ‘[Closed] My home page search filter is not working while changing language to italian.’ is closed to new replies.