This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.15 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 16, 2019 at 8:46 pm #4584093

aymanb-4

my problem with so from the error in the error_logs file I can see that the issue is caused by the sitepress-multilingual-cms plugin. Here is the log of the error:
[16-Sep-2019 20:41:09 UTC] PHP Fatal error: Uncaught Error: Class 'WPML_Translate_Link_Targets_Hooks' not found in /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/translation-management/class-wpml-translation-management-filters-and-actions.php:29
Stack trace:
#0 /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/translation-management/class-wpml-translation-management-filters-and-actions.php(10): WPML_Translation_Management_Filters_And_Actions->add_filters_for_translating_link_targets(Object(TranslationManagement))
#1 /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(94): WPML_Translation_Management_Filters_And_Actions->__construct(Object(TranslationManagement), Object(SitePress))
#2 /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/functions-load.php(306): TranslationManagement->__construct()
#3 /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/site in /home/deebturkey/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/translation-management/class-wpml-translation-management-filters-and-actions.php on line 29

September 17, 2019 at 11:44 am #4588067

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to manually update WPML Translation Management plugin and let me know if the issue persists?

You can download the Translation Management plugin from this link: https://wpml.org/account/downloads/

In this link you will find how to manually update WordPress plugins via FTP: hidden link

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

September 17, 2019 at 11:46 am #4588079

aymanb-4

I can't do anything
Because I can't open the wordpress panel
If you want I can send you cpanel access

September 17, 2019 at 12:18 pm #4588393

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I have set your next answer private and there you will find the needed fields to provide the access credentials in a secure way. Please share FTP credentials if you have them.

Looking forward to your message.
Regards,
Carlos

September 17, 2019 at 4:01 pm #4589965

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I moved String Translation and Translation Management plugins to a different folder and now the site is working again. Before we continue I kindly ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.

Please let me know when this is done.

Best regards,
Carlos

September 17, 2019 at 6:08 pm #4590613

aymanb-4

we took the steps you asked us to do
now it is ready

September 18, 2019 at 10:08 am #4594841

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I re-installed the String Translation plugins and Translation Management plugin and now the site is working correctly.

Could you confirm that the issue is solved?

Regards,
Carlos

September 19, 2019 at 10:20 am #4603527

aymanb-4

thank you very much
I have another problem in another site
And you specifically asked
You help me solve it
you can open this link : hidden link

September 19, 2019 at 10:54 am #4603849

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

As the original issue is solved I kindly ask you to open a new ticket and describe this new issue there. Then assign it directly to me and I will be more than happy to keep assisting you.

Regards,
Carlos