This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Izzi Hassan 1 month ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 20, 2019 at 2:29 am #4608775

ericqi

i creat a es.moxisys.com for my site. after translate. it not show properly. and i have checked the memory thing. they all meet your requirement. but still not show properly. please help me check.
thank you.

September 20, 2019 at 8:01 am #4610277

ericqi

I Removed and restored. but still have this problem. you cand check this link: hidden link i check use chrome check---->Console. and find show: Failed to load resource: the server responded with a status of 404 ()
it looks like that es.moxisys.com want to get some js,css, image from moxisys.com. but not succeed.
i do not how to fixed this. could you help me?
thank you

September 20, 2019 at 8:28 am #4610619

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

It seems like your server is not redirecting requests properly to the main site. This is usually due to an issue with your .htaccess file, or another server configuration problem.

Could you please provide us with a copy of your .htaccess file so we can take a look?

You should also check this page for information on setting up your server correctly for using the language domain option:
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

September 20, 2019 at 8:40 am #4610649

ericqi

Hi Izzi,
thanks for your reply.
below is .htaccess file please check

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

September 20, 2019 at 9:04 am #4610807

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for your response.

The .htaccess file looks fine. I see that you are using a plugin called “WP Rocket | Redirect HTTP to HTTPS”. Sometimes there can be compatibility issues between WPML and other plugins or unsupported themes.

To help us identify the problem, please try the following steps on your test or dev site:

  • Deactivate the “WP Rocket | Redirect HTTP to HTTPS” plugin and see if that resolves the problem
  • Deactivate all unnecessary plugins and leave only WPML plugins active. Check if the site is loading normally now
  • Activate plugins one by one and see if one of them causes the site to break again
  • Try changing the theme to a default one like Twenty Nineteen and check if the website loads properly, then change back to the current theme

Once you try these steps, please let us know what you find and we’ll be happy to assist you further.

September 20, 2019 at 9:23 am #4610955

ericqi

i tried what you said. still not work.

September 20, 2019 at 1:53 pm #4612815

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I can see that the 404 errors are due to the assets being fetched from the sub-domain rather than the main domain. This is due to an incompatibility with another plugin that is also trying to redirect visitors, or it is due to an incorrectly configured server.

In order for us to investigate further, I would also need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible
– in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

September 20, 2019 at 2:07 pm #4612927

ericqi

ok. how could i give you? leave relative information here or somewhere else?

September 20, 2019 at 2:16 pm #4612959

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Please reply to this message with the details. They will be securely and privately sent to us.

You will need to accept the disclaimers when sending this access. You should see instructions when you respond to this message.

September 21, 2019 at 10:01 am #4615773

ericqi

good day.
how is everything going? i really need to done this asap.
thank you.

September 22, 2019 at 5:42 am #4617359

ericqi

i test. if i use this option
Language name added as a parameter (hidden link - Spanish)
that page work well.

September 23, 2019 at 8:36 am #4621657

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Our team took a look at your site and we saw that using that option fixed your issue, but it did not explain why you are unable to use subdomains for languages. We still believe this to be an issue with how the server is configured, or configuration issues with one of your plugins.

I see that we no longer have access to WordPress. Did using “Language name added as a parameter (hidden link - Spanish)” resolve your issue?

September 23, 2019 at 9:01 am #4621845

ericqi

i have solved the problem.

September 23, 2019 at 9:16 am #4621907

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Glad to hear it!

Please don't hesitate to reach out if you have further issues with this, or any other topic.