Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by peterA-35 4 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
July 20, 2019 at 10:42 am

peterA-35

I am trying to: set up a main menu for Turkish the second language of my site

Cannot be seen because I had to deactivate WPML to get into my dashboard

I expected to see a new Turkish main menu

Instead, I got: site crashed

July 20, 2019 at 1:34 pm #4249955

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for contacting us.

Could you check the solution in this post and see if it works for you? Please do not forget to take a backup before attempting it.
https://wpml.org/forums/topic/invalidargumentexception-element_id-and-type-do-not-match-for-element_id/#post-4032419

July 21, 2019 at 11:40 am #4252125

peterA-35

Hi Laura, I wasn't too sure what you were asking me to do and I was not very confident to make any changes. I decided to restore a backup, which I did and set everything up all over again. I translated the homepage successfully and I then went to sync menus and the site crashed again. Not sure what to do now?
Thanks and Kind Regards

July 21, 2019 at 5:17 pm #4252871

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

Do you still get the same error?

The error you were getting shows there is some problem with the database, and we need to remove the problematic entry. I don't have access to the database, that's why I sent you instruction.
If you are not sure about what to do, I can try to fix it but I'd need to install an additional plugin and you must be sure to have a working backup in case something goes wrong.

July 21, 2019 at 5:52 pm #4252885

peterA-35

I would be very grateful if you would do this for me. I confirm that I have a working backup so you can go ahead with the additional plugin. Thanks so much for your help.

July 22, 2019 at 6:34 am #4254203

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

the provided credentials do not work, I get a wrong password message.

July 22, 2019 at 7:12 am
July 22, 2019 at 9:05 am #4255107

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I accessed the site and the issue should be fixed now. I tried to open the translated menu in Turkish and it's not returning any error, so you should be able to create it.

Let me know if you need further assistance.

July 25, 2019 at 6:51 am #4279623

peterA-35

My issue is resolved now. Thank you!