This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The sidebars are missing in my secondary languages.

Solution: This issue was caused by a custom theme. Switching to a default theme resolved the issue.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 1 year, 5 months ago.

Assigned support staff: Lauren.

Author Posts
May 8, 2018 at 4:01 pm #2035866

Ido Fishman

i have installed WPML on my WordPress website and the website doesnt show the Main Sidebars on the secondary languages..

The sidebar appearing on the main language hebrew only..

HEBREW: hidden link [You can see sidbar with search and categories]

ENGLISH: hidden link [NO SIDEBAR]

ARABIC: hidden link [NO SIDEBAR]

i am using WPML Widgets plugin and selected all languages option on the admin for widgets..

here is the admin access:

Admin
hidden link
techit
THOh%EJ8k2

May 9, 2018 at 7:11 pm #2060246

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

What theme are you using? Some themes do not work with the All Languages option for widgets. If you try adding a separate widget and then assign each widget to a language, does the sidebar show the widgets? Also, for the archive widgets, have you translated your posts to your secondary languages?

Please make sure your website meets the minimum requirements found here: https://wpml.org/home/minimum-requirements/

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

May 10, 2018 at 12:52 pm #2071700

Ido Fishman

you can see that i have given the site admin login access and the site is using a custom made theme..

can you please login as admin and have a look?

May 10, 2018 at 1:03 pm #2071861

Ido Fishman

The post archive that appears on the secondary language pages are comes from the code not from the widgets, if there is no widgets i coded it to appear the default archive links..

May 10, 2018 at 2:30 pm #2074252

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please test your site with a default theme and using widgets. If the archives display correctly in the secondary languages with those settings, then it looks like there is a problem with your custom code. Per our support policy, I am unable to offer a custom code solution, but i can suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/ for further assistance.

May 10, 2018 at 5:38 pm #2077868

Ido Fishman

OK, i understand thanks for your time and reply.. what i wanted to know is 2 things..

1. Document to setup each widget for each language..
2. I am using separate theme directory and files for each language, for example:

For Arabic - "ar.beitissie"
For English - "en.beitissie"
For Hebrew - "he.beitissie"

is this anything related to this issue? but widget coding are same on all - i just cloned one theme into others on appropriate names..

please answer this 2 questions that will be enough for me to fix this issue..

Thanks
Jay

May 10, 2018 at 6:42 pm #2078515

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

1. To use different widgets for each language, first create the widget. Then, check the box to make it multilingual and save. Then assign it to the language you would like it to display on. Repeat these steps for each widget.

2. This could be why you are having issues. I don't think it will work correctly to have separate directories for each language. To use this domain structure, you should follow the documentation here: https://wpml.org/2016/04/use-wpml-different-domains-per-language/