This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 8, 2019 at 2:21 pm

chinomsoG

I am trying to: activate WPML and it's components

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

April 8, 2019 at 5:44 pm #3560453

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please let me know the following details for tracking the issue.

a) Which version of WPML you have activated on the site. Please try with WPML 4.2.5(the latest version)

b) Are you configuring the WPML for the first on this site

c) Do you have the redirection issue on the frontend of the site? Please share more details about it

d) Please activate WPML core plugin only and make sure the issue is existing or not

--
Thanks!

Bigul

April 10, 2019 at 2:44 pm #3577517

chinomsoG

Hi Bigul, thanks for your help.

These are the answers to your questions

a.) The version of WPML activated on my site is v4.2.5

b.) This is the first time I am configuring WPML on my site, yes.

c.) I have the redirection issue on the frontend of my site as well as the backend/admin of my site, I am unable to have access as an admin and as a visitor to the site.

d.)I have activated the WPML core plugin and the issue is not existing. I have not activated the other components/plugin.

Observation: from my observation, the redirect error happens once i activate the "translation management component"

April 10, 2019 at 4:38 pm #3578815

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

April 11, 2019 at 11:20 pm #3593233

chinomsoG

Hello Bigul,

thanks for your help, you have asked me to reset my site which will make the third time I will have reset the site and activated the WPML plugins one after the other to catch the one causing this issue and still ended up with this same error. apart from losing all previous work and still having the same challenge, this has stalled work on the site and is a major concern.

what I have noticed however is that this error(site redirected too many times) kicks in when I activate the "Woocommerce Multilingual" plugin.

please look into this as I just want the site working and client is very worried about this issue. thanks.

April 12, 2019 at 6:15 am #3595035

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

April 12, 2019 at 9:08 am #3596907

chinomsoG

Thanks for all your help Bigul,

please I would like to know if there's anyway i can help with your suggested method of making a duplicator copy of the site so you can debug on your local server.
let me know if there's any particular thing you need me to do.
thanks

April 12, 2019 at 4:45 pm #3600647

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I had some issues while creating the Duplicator package. But finally able to create it. Please check the attached images.

I get the network errors while downloading the Duplicator file. So it will be great if you can share the FTP credentials of the site.

--
Thanks!

Bigul

April 13, 2019 at 3:45 pm
April 13, 2019 at 4:01 pm
April 13, 2019 at 4:05 pm #3605083

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the SFTP details, it is working for me. Please check my last reply.

--
Thanks!

Bigul

April 16, 2019 at 7:52 pm #3625247

chinomsoG

hello,

please how do i request a refund, the client has requested to start the process. thank you

April 17, 2019 at 7:18 am #3627683

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the update. Please visit the following URL and fill the refund form.

https://wpml.org/purchase/refunds-policy/

Please let me know if you need any further assistance.

--
Thanks!

Bigul

The topic ‘[Closed] my site gives redirect error once i activate WPML components’ is closed to new replies.