This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by saraL-16 6 days, 8 hours ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 20, 2020 at 8:45 am #6175449

saraL-16

I am trying to: see the slider at the top of my english version home page

Link to a page where the issue can be seen:hidden link

I expected to see: the slider just like it appears in the default language hidden link

Instead, I got: the slider disappeared. I tag the image as 'slider' but it seems to not work in the english version.

May 21, 2020 at 12:55 am #6181905

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look at your website and could confirm the issue, it seems to be caused by some differences in the page settings of your default and secondary languages. Please, try the following:

1 - Click to edit your homepage from your WordPress Dashboard > Pages settings;

2 - Change to the the secondary language (english) using the top admin bar language switcher, then review any slider settings and make sure you have the exact same settings of your default language page.

Please, let me know if it helps, have a nice day.

May 21, 2020 at 10:45 am #6185753

saraL-16

Hi Marcos,

Many thanks for your help this - the issue is that our homepage is dynamic, it's created with the recent entries but it doesn't exists as a page.

Thanks in advance.

Sara

May 22, 2020 at 1:02 am #6191101

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Sara,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 26, 2020 at 12:55 am #6214141

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Sara,

Thank you for the updates and sorry for the waiting here due the weekend. I checked your WordPress Dashboard and noticed you don't have a translation for the post 'QUIÉN NECESITA A LOS HUMANISTAS' as your slider data is being provided by this post you would need a translation with content and featured image in order to show some content in the translated slider. Please, let me know if you need any additional clarifications and details, have a nice day.

May 26, 2020 at 7:38 am #6216101

saraL-16

Hi Marcos,

Thank you for this - Truth is that I had issues to translate this article so I decided just to create one directly in English. Nevertheless, the slider is supposed to feature as much images as I want if I tag the article as "Slider", but another two articles are tagged too and none of them is appearing in the slider either.

Thanks,
Sara

May 27, 2020 at 8:03 pm #6232715

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Sara,

Thank you for the updates. I took a detailed look at your website and noticed you have two posts with the 'slider' tag assigned and your slider shows exactly the two posts, I also noticed you added translation for these two posts and now your translated page shows your slider with the translated articles properly. So, everything is working as it shoud, do you still see any issue related to it? Please, let me know, have a nice day.

May 28, 2020 at 3:37 pm #6241191

saraL-16

Hi Marcos - Yes, it is working properly now. We found out that it was the theme, as it was not available in WP anymore so we had to buy it again, and with the translation of both posts now works perfectly.

Many thanks for you assistance on this.

Have a nice day you too.