Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: the menu in the theme FRWD doesn't retain the CSS in the second language

Solution: you need to do a small edit to the theme. See Relevant Documentation.

Relevant Documentation: https://wpml.org/forums/topic/my-spanish-translated-menu-layout-design-bar-is-different-from-the-original/#post-4099313

This topic contains 11 replies, has 2 voices.

Last updated by kathrinR-2 5 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
June 26, 2019 at 7:16 am #4089935

kathrinR-2

Tell us what you are trying to do?
I have the template FRWD. I tried to make changes on the menu options. The layout design works with push menu perfectly but not with the classic bar menu.

Is there any documentation that you are following?
No, just the one described on your web.

Is there a similar example that we can see?
Check out the attached Screenshots to get an idea.

What is the link to your site?
hidden link (Change the language to spanish to see the issue)

June 27, 2019 at 10:48 am #4099313

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I found a solution for you, I tested on the copy and as you can see it's working: hidden link

You need to do a small change in your theme code. If you can't access your site via FTP, you can do it in Appearance > Theme editor.

Select the file FRWD/includes/classes/iron_fwrd_setup.class.php
and at line 438 change

$custom_styles_url = home_url('/').'?load=custom-style.css';

with

if(ICL_LANGUAGE_CODE == 'en') {
        $custom_styles_url = home_url('/').'?load=custom-style.css';
    } else {
        $custom_styles_url = home_url('/').'?lang=es&load=custom-style.css';
    }

This should solve the issue.

Let me know if this helps you or if you need further assistance.

June 27, 2019 at 6:58 pm #4102313

kathrinR-2

Hi Laura,

I tried to enter the code but it didn't solve the problem 🙁 I got an error message: check out the attached screenshots for details...maybe you can see what's wrong?

Best, Katy

June 28, 2019 at 10:58 am #4106713

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Katy,

this kind of error usually happens because the theme is the active one.

You can switch to another theme, apply the change and re-activate FRWD, it should work (please backup your site before attempting it).

Otherwise, you can apply the change via FTP.

June 29, 2019 at 7:15 am #4111225

kathrinR-2

Hi Laura,
I've been trying to access my FTP now for 2 days...no chance... and I don't know how to make a backup, to make the change directly in WordPress...this is so complicate 🙁

June 29, 2019 at 7:46 am #4111263

kathrinR-2

Laura...I think I destroyed my website :((

June 29, 2019 at 8:05 am #4111299

kathrinR-2

UPDATE: My site is working again, thankfully I had a backup via plugin. But it still didn't work out through the WordPress changing the Theme.
I'm trying to contact now my webhoster to solve the FTP issue. And then I have to figure out how to make changes via FTP - I hope it works...

June 29, 2019 at 12:42 pm #4111577

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

if you don't have FTP access you can access files on your server with a plugin like File Manager (there are several around). Again, be sure to backup your site before doing changes to your files.

June 30, 2019 at 10:06 pm #4114967

kathrinR-2

Hi Laura,
here is my update. Problem is still unsolved...
I was able to enter the site via FTP. I copied the code you've provided to iron_fwrd_setup.class.php and it happened the same as in WordPress. The Website just crashed - but no worries, I have my backups 🙂 . I did a screenshot of the failure message..
Hmmm...tricky thing!

July 1, 2019 at 7:26 am #4116093

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

that error message could be anyhting, we need to see the specific error, so please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

July 1, 2019 at 9:47 am #4117407

kathrinR-2

Hey Laura,
Ok, I followed your instructions but my wp-content folder doesn't have a debug.log or any error log files...BUT it doesn't matter - that's another issue I have to figure out by myself.
BEACUSE Check this out: hidden link

Now it's working, the error disappeared! I have NO IDEA what I did, but the issue is solved 😀
Actually it worked after I inserted & erased

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

No idea if that solved the problem...but something worked.
Thank you very much for your help and patience, I was really trying to figure out this since January...hahaha.
Have a great start into the weekend!
Much peace & Love
Katy

July 1, 2019 at 9:48 am #4117423

kathrinR-2

Thank you, Laura, for your time, patience and help! Problem solved 🙂