Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Andreas W. 6 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
October 28, 2020 at 12:13 pm

martinH-16

Hello there, I used this solution: https://wpml.org/forums/topic/wpml-and-oxygen-doesnt-work-at-all/ but it stopped working today, my templates are not copied at all after complete translation in advanced editor. Please help.

October 28, 2020 at 12:38 pm
October 28, 2020 at 1:37 pm #7325909

martinH-16

Another badly translated page: hidden link

October 28, 2020 at 1:39 pm #7325921

martinH-16

Also!!!! You told me, you will not do any changes, but I found you change all custom fields starting with ct_ to copy. You propably did a big mistake and my sites is permanently demaged. Who will do all the work again???

October 28, 2020 at 3:00 pm #7326675

martinH-16

Another translated page with not working translations: hidden link

I dont see any I can't find any coincidence in that bad pages 🙁

October 28, 2020 at 3:59 pm #7327333

martinH-16

Also another page - hidden link

What is strange and special here - gutenberg content does not appear in translation editor here...

October 28, 2020 at 4:12 pm #7327645

martinH-16

Another page - hidden link completely missing gutenberg editors content in ATE

October 28, 2020 at 5:31 pm #7328409

martinH-16

Another page failed: hidden link

October 28, 2020 at 5:34 pm #7328423

martinH-16

Another: hidden link

October 30, 2020 at 12:34 am #7339995

martinH-16

Hey, can someone help me finally? I have a duplicator package ready to send to you guys

October 30, 2020 at 3:49 am #7340955

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The Gutenberg Block Text is not showing up inside the Editor, as you are using Oxygen Templates, which are not set as translatable and not translated.

I have adjusted the setting now and I would like to ask you to translate all templates at Oxygen -> Templates.

Further, I have set the custom field "ct_page_settings" to "copy", as this file dhandles the theme options and need sto be set to "copy" in order to maintain the same layout and design on all pages.

Let us know if you are still experiecing issues after translating the templates.

Best regards
Andreas

Templates.PNG
November 5, 2020 at 7:07 pm #7388871

martinH-16

Hello Andreas, but I dont want to translate the Templates!! Templates are still same, they are using completely dynamic data.

All content is generated from gutenberg & ACF fields. There is nothing to change in Oxygen templates. THats why they shouldnt be translated.

Why do you think ct_page_settings is the right one? I already said the right one is ct_other_template. And it works on some pages. I dont think this is a solution. And I dont have a time to translate the templates. I dont know how to translate them at all. They are just a bunch of shortcodes.

So?..

November 6, 2020 at 5:32 pm #7395359

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry, but you reply was a little confusing which for I have a few questions.

The page use Gutenberg and ACF. In fact it appears to me that you are not using Gutenberg. You are using the Oxygen Front-End Builder in order to display ACF fields which seems not to work out.

A workaround here would be using a theme page template by suing the get_field function:
hidden link

Regarding your example hidden link:

Those ACF field are displayed with Oxygen which might be the source of the issue.

I would like to ask you to install Oxygen and ACF PRO on the following test site for furthe investigation. I would also appreciate if you could iimport the "Jídelní lístek" Filed Group for testing:

One-Click-Login:
hidden link

Please do not forget to leave me a short notification once the site is ready for testing.

Best regards
Andreas

November 12, 2020 at 7:23 pm #7437899

martinH-16

I already created complete site clone for second support engineer. https://wpml.org/forums/topic/hello-same-problem-as-yesterday-but-i-finally-found-what-is-happening/ please get the login from him. thanks!

I also write complete step by step to the issue:

Hello Dražen, Ok then,

1) Open Admin
2) Go to pages, find page HRR Catering
3) Open it in czech language - you can see the content.
4) Open translation editor - you can see translations.
5) Open frontend, change language from czech to other - english/german - > what you can see? Page without inner content.

hidden link - CZ, working
hidden link - DE, not working
hidden link - EN, not working

6) What I have found? The ct_other_template is not copied, when it is set up to Copy with WPML. It happens only on some pages.
7) Go to CZ version, click edit page, go to oxygen section, show all shortcodes, copy them
8) Go to EN or DE version, edit page, paste the shortcodes to the oxygen section.
9) save and open page on frontend - > it works, huh? (Yes, you copied the ct_other_template manually)
10) Open CZ version of page again, and open the translation of language, where you changed the shortcodes manually.
11) It opens classic WPML editor, without ACF fields, etc..

can you help me?? I need it ASAP because we need to run the site next month.

November 13, 2020 at 1:47 am #7439035

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It appears to me that this seems to be a compatilbity issue between Oxygen, ACF and WPML and in order to escalate this issue I do need to verify, if the same problem also exists on a new WordPress install.

I would like to ask you again to install Oxygen and ACF PRO in their latest versions on the following test site for further investigation. I would also appreciate if you could import the "Jídelní lístek" Field Group for testing:

One-Click-Login:
hidden link

If you even find the time to recreate the page with Oxygen it would be very helpful and save time.

Please let me know if the issue is occuring on this new WordPress install as well. If this is the case I will debug and escalate the issue towards our compatibilty team for further revission.

Best regards
Andreas

The topic ‘[Closed] My templates are not copied’ is closed to new replies.