Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Yvette 7 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
March 14, 2019 at 10:16 am #3342749

pierreL-28

I am trying to:

Link to a page where the issue can be seen: hidden link

All the translated fields are correct in the back

but the translation won't display on the front side

Please help

March 14, 2019 at 10:35 am #3343049

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Please make sure that the translation is marked as complete. Maybe when it is redelivered from the Advanced Translation Editor, it was not marked as complete. This could happen because of a caching system, or if the translation was already taken by a different translator.

Can you try with a new page, does it get translated or does it present the same issue ?

I also noticed that you are using the Advanced Custom Fields plugin, we have our glue plugin Advanced Custom Fields Multilingual that makes sur all fields are correctly translated. See your download page https://wpml.org/account/downloads/

Best regards,
Jamal
WPML Support

March 14, 2019 at 10:43 am #3343087

pierreL-28

Hello Jamal,

Thanks for your answer work with a new page...
As you can see on the screenshot The translation ID 25 is completed.
It might be a caching problem.

I don't use the plugin Advanced Custom Fields so I will deactivate it.

March 14, 2019 at 4:22 pm #3346961

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. And my apologies for the late reply.

Have you been able to purge cache and save translation again ?
What if you disable caching and save translation again ?

As this is working for other pages and not this one, maybe the page is using something special, not used in other pages, like a visual editor block, or a custom shortcode that is not handled well by WPML.
Would you like to allow me temporary access to see this closer ? Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal
WPML Support

March 15, 2019 at 9:30 am #3352379

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for the access. I also tried to translate the page "nos vins" without success. I send the page to translation again through WPML->Translation Management(Gestion de Traduction).
I made a small change and updated then retranslated=> No results.
I was always deleting cache.
Tried with a new private page (WPML Test). That was translated successfully.
I deleted the page package in WPML->Packages(Paquetages).
I updated WPML->Settings(Paramètres)->Custom XML Configuration with our WPBakery reference configuration file hidden link.

I noticed that the english translation has the slug changed from "our-wines" to "nos-vins", i imagine you deleted the page translation and translated again! If it is not the case, would you try to remove the page translation and try again. You can do that as follow.
1. Go to Pages->All Pages.
2. Switch to English from to admin top bar language switcher.
3. Delete the translated page. Then remove it permanently from the trash.
4. Switch back to French and try to translate the page again.

I'll be waiting for your reply.

Best regards,
Jamal
WPML Support

March 15, 2019 at 1:02 pm #3354171

pierreL-28

Unfortunately, I deleted the English page I tried again... and it still doesn't work...

How is this possible, it seems that it just wants to copy the French and don't use the English text?

March 15, 2019 at 2:04 pm #3354465

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Please allow me to take a Duplicator snapshot of your website. I would like to test it locally.
Once the problem is resolved I will delete the local site.

Best regards,
Jamal
WPML Support

March 15, 2019 at 2:10 pm #3354475

pierreL-28

ok no problem

March 15, 2019 at 3:19 pm #3355085

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you, i download the duplicator package and will let you know about it as soon as possible.

Best regards,
Jamal
WPML Support

March 15, 2019 at 9:51 pm #3357009

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I couldn't find a solution to this issue. The ticket is now escalated to our developers for further analysis. we will come back to you as soon as possible.
Thank you for your patience.

Best regards,
Jamal
WPML Support

March 18, 2019 at 2:08 pm #3370083

pierreL-28

Hello Jamal

Thanks for your answer...
It seems to affect also my main home page.

March 18, 2019 at 3:12 pm #3370635

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I escalated this information to our developers. I will inform of any progress as soon as possible.

Best regards,
Jamal
WPML Support

March 25, 2019 at 2:41 pm #3454979

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Our sincere apologies for the late reply. Our developers did not find any issue within ATE server related the this specific page. And they think that there are just a workflow issue. For example, the translation was opened from WPML->Translations, and from the original page editor links, which may create an inconsistency.
We suggest to resend the page for translation through WPML->Translation Management. I wanted to test it, but i found the translation was removed.

Would you like to create the translation again ?

I would also like to know if this is happening with another page ? I wanted to test this, both pages (e-shop and mon compte) which need translation updates are translated through the CTE.

Please tell me if there is anything i can help with.

Best regards,
Jamal

March 25, 2019 at 5:53 pm #3456993

pierreL-28

Hello Jamal,

I try to delete the page and traduction but it seems that they are still in the database...

I sended again the traduction via the traduction manager but it still don't work

I also desactivated the advanced translator... but nothing.

same problem with the page My wines

March 27, 2019 at 8:52 am #3468771

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I just tried the same again without success.
So i will escalate again to our developers for more investigations. And will get back to you as soon as possible.

Best regards,
Jamal

The topic ‘[Closed] my translations won't display on the page’ is closed to new replies.