This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 6 months ago.

Assigned support staff: Bruno Kos.

Author Posts
April 19, 2019 at 10:28 am #3644919

ajchJ

I am trying to: run a plugin used by multiple WPML users before, but when I'm running it, my front and backend goes blank

Link to a page where the issue can be seen: it can't be because my site is not online when I get this.

I expected to see:
a new recipe template

Instead, I got:
an error message:
[Fri Apr 19 11:42:20.753377 2019] [lsapi:error] [pid 2356410:tid 139664581154560] [client 141.138.169.221:55143] [host hidden link; Backend fatal error: PHP Fatal error: Uncaught InvalidArgumentException: element_id and type do not match for element_id:93379 the database contains post_recipe while this function was called with post_post in /home/deb117070/domains/byandreajanssen.com/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32\nStack trace:\n#0 /home/deb117070/domains/byandreajanssen.com/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1484): WPML_Set_Language->set('93379', 'post_post', NULL, 'nl', NULL, true)\n#1 /home/deb117070/domains/byandreajanssen.com/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1888): SitePress->set_element_language_details('93379', 'post_post', NULL, 'nl')\n#2 /home/deb117070/domains/byandreajanssen.com/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1858): TranslationManagement->add_missing_language_to_post(Objec in /home/deb117070/domains/byandreajanssen.com/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32\n, referer: hidden link

April 19, 2019 at 10:51 am #3645075

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me this solution works for you?
https://wpml.org/forums/topic/fatal-error-uncaught-exception-invalidargumentexception-with-message-element-5/#post-1210126

Regards,
Bruno Kos

The topic ‘[Closed] My website goes blank (front and ensdside)’ is closed to new replies.